error with chimera.uchime

I am getting the following error message when i tried to use the chimera.uchime
[ERROR]: /home/X/common/sl/bin/mothur/uchime file does not exist. mothur requires the uchime executable.
[ERROR]: did not complete chimera.uchime.

I looked up previous posts for this error. I have the executable in the same directory as mothur but it did not work. so i moved it to my current working directory. it still did not work. i have the most recent version of mothur.
not sure what is happening.

any suggestions?


So uchime is in the /home/X/common/sl/bin/mothur folder, and it’s not working? Have you tried running /home/X/common/sl/bin/mothur/uchime to make sure the uchime executable works. It should give you a usage error, but will help us rule out some possible reasons for the problem.

Thanks for the reply.
I am able to run uchime from anywhere , not restricted to directory where i have mothur. just uchime on the command prompt gives me different options for uchime, so looks like i am able to execute it.
hope this helps.


What you you get when you run?

imac:Debug SarahsWork$ which uchime

imac:Debug SarahsWork$ which mothur

Thanks for the reply. This is what i get after doing which

[kazima@n077 SchlossSOP]$ which uchime

[kazima@n077 SchlossSOP]$ which mothur


Okay, so it appears mothur isn’t quite getting the path’s right. Mothur thinks uchime is in /home/X/common/sl/bin/mothur/, but your uchime executable is in /home/X/common/sl/bin/. I will look into fixing this, but here’s a workaround to help me continue your analysis.

  1. Create a folder called mothur in /home/X/common/sl/bin/
  2. Put a copy of the uchime executable in the new mothur folder.