chimera.uchime Error

Hi all,

I’m trying to run the chimera.uchime script with my trimmed and unique sequences fasta file and I keep getting this error:

mothur > chimera.uchime(fasta=stability.trim.contigs.good.unique.good.filter.fasta, count=stability.trim.contigs.good.unique.good.filter.count_table, dereplicate=t)

Unable to open /Users/laurenoconnell/Desktop/Thesis_Data/stability.trim.contigs.good.unique.good.filter.fasta. Trying output directory /Users/laurenoconnell/Desktop/Thesis_Data/mothur/stability.trim.contigs.good.unique.good.filter.fasta
Unable to open /Users/laurenoconnell/Desktop/Thesis_Data/stability.trim.contigs.good.unique.good.filter.count_table. Trying output directory /Users/laurenoconnell/Desktop/Thesis_Data/mothur/stability.trim.contigs.good.unique.good.filter.count_table

Using 1 processors.
/Users/laurenoconnell/Desktop/mothur/uchime file does not exist. Checking path…
[ERROR]: file does not exist. mothur requires the uchime executable.
[ERROR]: did not complete chimera.uchime.

I’ve tried changing my directory but I am still getting the same error.

Does anyone have any suggestions on how to get this command working?

mothur doesn’t perform uchime itself, it runs uchime as a separate program. It looks like you don’t have the executable (or don’t have it where mothur expects it). Have you moved mothur from where you originally downloaded/compiled it? If so, see if uchime is there and stick it wherever you’re running mothur from.

If you need the uchime executable. It is available for download with our mothur executable versions,

I did move my mothur folder from where I downloaded it originally. I moved everything back and was able to get it running. Thanks, much!