error for uchime and chimera slayer on linux system

I am currently running mothur on a linux server system. When I use the uchime command I receive the following error message
Using 1 processors.
/usr/local/bin/uchime file does not exist. Checking path…
[ERROR]: file does not exist. mothur requires the uchime executable.
[ERROR]: did not complete chimera.uchime.

I also get the following error messages when I try chimera slayer
Only reporting sequence supported by 90% of bootstrapped results.
[ERROR]: /usr/local/bin/blast/bin/formatdb file does not exist. mothur requires formatdb.exe.
[ERROR]: /usr/local/bin/blast/bin/blastall file does not exist. mothur requires blastall.exe.
[ERROR]: /usr/local/bin/blast/bin/megablast file does not exist. mothur requires megablast.exe.

I have run the analysis on a stand alone desktop with the same files it works okay. Does anyone know how to fix the error on the linux system?

For chimera.uchime, did you try moving the uchime executable to /usr/local/bin/uchime? For chimera.slayer, you can move the blast folder to /usr/local/bin, or set your blast location using the blastlocation parameter.


We encountered the same problem. We tried to create a “local” library in our user name directory as suggested but with no success. It look like Mothur cannot find the UCHIME.

Any suggestions?

thank you

I’ve never had this problem on our linux computers, but I have noticed that if you try to run mothur installed in the QIIME virtual machine, the same problem happens with uchime - it’s in the same directory as mothur, but can’t be found.

Have you tried putting uchime in the same folder as mothur’s exe?

i have encountered a similar problem. May i ask what is the uchime executable?? I have downloaded both “gold” database and uchine2.40 from their site but nothing worked.shall i change the name of the file or something ?

The uchime executable is released with the executable versions of mothur, It is also built as part the build process when you build mothur from source yourself. The file will be named uchime on Linux/Max machines, or uchime.exe on Windows machines. Mothur’s wrapper command, chimera.uchime, is design to work with the version of uchime released with mothur’s executable and source. Mothur’s chimera.uchime command prepares the inputs, runs the uchime executable, and assembles the results.