chimera.slayer: could not open file

I am running Ubuntu 11.01. I have downloaded and successfully compiled mothur from the source code. Within the Mothur.source folder I have the directory blast/bin with megablast and formatdb binaries (I downloaded and extracted this file: blast-2.2.16-ia32-linux.tar.gz, renamed the directory to ‘blast’).

However, when I try to use chimera.slayer, I get this message:

mothur > chimera.slayer(fasta=RC_slug9.unique.align, template=…/silva.gold.align)

Checking sequences from RC_slug9.unique.align …
Reading sequences from …/silva.gold.align…Done.

Only reporting sequence supported by 90% of bootstrapped results.
[ERROR]: Could not open RC_slug9.unique.149277576.candidate.unaligned.fastaRC120-9::G2PF4LZ04JWBGI
[megablast] WARNING: Unable to open output file RC_slug9.unique.149277576.blastRC120-9::G2PF4LZ04JWBGI:
[megablast] FATAL ERROR: blast: Unable to open input file RC_slug9.unique.149277576.candidate.unaligned.fastaRC120-9::G2PF4LZ04JWBGI

Mothur then just sits there. It’s using up CPU, but nothing else happens.

Here is the formatdb.log if it helps:

========================[ May 18, 2011 4:36 PM ]========================
Version 2.2.16 [Mar-25-2007]
Started database file “RC_slug9.unique.149277576.template.unaligned.fasta”
NOTE: CoreLib [002.003] FileOpen(".formatdbrc",“r”) failed
NOTE: CoreLib [002.003] FileOpen("/home/rockx/.formatdbrc",“r”) failed
NOTE: [000.000] No number of link bits used found in config file. Ignoring
NOTE: [000.000] No number of membership bits used found in config file. Ignoring
Formatted 5181 sequences in volume 0
SUCCESS: formatted database RC_slug9.unique.149277576.template.unaligned.fasta

Here are the current files within the folder that I am running Mothur from:

formatdb.log
mothur.1305689071.logfile
mothur.1305700514.logfile
RC_slug9.fasta
RC_slug9.fasta.summary
RC_slug9.names
RC_slug9.unique.149277576.template.unaligned.fasta
RC_slug9.unique.149277576.template.unaligned.fasta.nhr
RC_slug9.unique.149277576.template.unaligned.fasta.nin
RC_slug9.unique.149277576.template.unaligned.fasta.nsd
RC_slug9.unique.149277576.template.unaligned.fasta.nsi
RC_slug9.unique.149277576.template.unaligned.fasta.nsq
RC_slug9.unique.align
RC_slug9.unique.align.report
RC_slug9.unique.fasta
RC_slug9.unique.slayer.accnos
RC_slug9.unique.slayer.chimera
RC_slug9.unique.slayer.chimeras.tempHeader

Hi,
I’m having a very similar problem. I’m running mothur last version in Ubuntu. I want to run chimera.slayer, and I’ve installed blast (blast-2.2.16-ia32). I’m getting this:

mothur > chimera.slayer(fasta=STR_6743seqs_200511_core_blast_min700bp.align.fasta, template=/home/ramiro/Documents/DB/Biomarks/Laure/VersionFeb2011/Laure_DB_aligned/18S_1800_2000bp_Coreset_preliminar_Align_RL/18S_1800_2000bp_Coreset_preliminar_Align_12017seq_RL.fasta, processors=4)

Checking sequences from STR_6743seqs_200511_core_blast_min700bp.align.fasta …
Reading sequences from /home/ramiro/Documents/DB/Biomarks/Laure/VersionFeb2011/Laure_DB_aligned/18S_1800_2000bp_Coreset_preliminar_Align_RL/18S_1800_2000bp_Coreset_preliminar_Align_12017seq_RL.fasta…Done.

Only reporting sequence supported by 90% of bootstrapped results.
sh: Syntax error: end of file unexpected


Mothur won't quit, instead it keeps running at 100%, but nothing happens. Same input files with chimera.slayer in the previous version of Mothur works fine.

formatdb.log looks like this:
========================[ May 20, 2011 9:03 AM ]========================
Version 2.2.16 [Mar-25-2007]
Started database file “STR_6743seqs_200511_core_blast_min700bp.align.29317463.template.unaligned.fasta”
NOTE: CoreLib [002.003] FileOpen(".formatdbrc",“r”) failed
NOTE: CoreLib [002.003] FileOpen("/home/ramiro/.formatdbrc",“r”) failed
NOTE: [000.000] No number of link bits used found in config file. Ignoring
NOTE: [000.000] No number of membership bits used found in config file. Ignoring
Formatted 12017 sequences in volume 0
SUCCESS: formatted database STR_6743seqs_200511_core_blast_min700bp.align.29317463.template.unaligned.fasta

Any suggestions?

thanks!

To rockx:

When mothur runs the megablast command to find the potential parent pool, it creates a file that ends with the sequence name. It looks like your sequence names contain ::. We had a similar error report from a Windows user, and when he replaced ::, with _, it ran fine. Want to give it a try?

This works perfectly. Thanks :slight_smile:

Another error here, this time with Windows7 and the Win version of Mothur. Chimera.slayer reports no errors, however no chimeras are detected in an alignment with known chimeras (Linux Mothur detected 30 chimeras).

Could you send the Windows .chimera and Linux .chimera file to mothur.bugs@gmail.com?

Thanks for bringing this to our attention. This is actually an error with the setup of formatdb.exe for windows, which causes megablast not to find any potential parent matches. We uploaded a new version of mothur that has a warning message it this occurs. The new version also includes blast version 2.2.25.

Thanks for the quick update :slight_smile:

Just a thing to note, when I tried chimera.slayer with the new win Mothur on the dataset the formatdb error occurs, but all chimeras detected in the linux/mac versions are still properly detected even with the error.

I am using Mothur V1.20.1 and I am getting the following error message when I run chimera.slayer against silva database
megablast returned 0 potential parents for all your sequences. This could be due to formatdb.exe not being setup properly, please check formatdb.log for errors
the formatdb.log states ERROR: Could not open self106451168317505.template.unaligned.fasta
I get the same error when I use my sequences as the database for chimeraslayer.

I started preprocessing my dataset in April, before the recent updates, and at that time over 36,000 chimeras were detected. Now, when I rerun the new commands on the same dataset, there are problems. I have the latest version of Mothur, and it only finds four chimeras when I use this command: >chimera.uchime(fasta=McHughB.trim.unique.good.filter.unique.precluster.fasta, name=McHughB.trim.unique.good.filter.unique.precluster.names).

When I try other options, this is what I get:

chimera.slayer(fasta=McHughB.trim.unique.good.filter.unique.precluster.fasta, name=McHughB.trim.unique.good.filter.unique.precluster.names)
Only reporting sequence supported by 90% of bootstrapped results.
[NULL_Caption] ERROR: Could not open self243671296683758.template.unaligned.fasta

chimera.slayer(fasta=McHughB.trim.unique.good.filter.unique.precluster.fasta, reference=silva.gold.filter.fasta, processors=2)
[NULL_Caption] FATAL ERROR: Database McHughB.trim.unique.good.filter.unique.precluster.13511496057939.template.unaligned.fasta was not found or does not exist
[NULL_Caption] WARNING: Unable to open McHughB.trim.unique.good.filter.unique.precluster.13511496057939.template.unaligned.fasta.nin

I can’t find a file with …ng.fasta, so I tried substituting “nogap”.

chimera.uchime(fasta=McHughB.trim.unique.good.filter.unique.precluster.fasta, reference=nogap.bacteria.fasta, processors=2)
This method found 6 chimeras.

@ CDU:
When you are running your sequences with the silva reference, are you also using a name file?

@tmchughie:
For the command: - “chimera.slayer(fasta=McHughB.trim.unique.good.filter.unique.precluster.fasta, name=McHughB.trim.unique.good.filter.unique.precluster.names)” Did mothur complete the chimera.slayer command? I suspect the error you are getting is a nuisance error. When you use the more abundant sequences as a reference to check the other sequence,the most abundant sequences have no reference. We are working on removing this error.

For the command: - “chimera.slayer(fasta=McHughB.trim.unique.good.filter.unique.precluster.fasta, reference=silva.gold.filter.fasta, processors=2)” It seems like the formatdb/blast commands did not run correctly. Could you send the entire logfile and any additional screen output from blast to mothur.bugs@gmail.com?