mothur

Pre.cluster hanging on sample processing

I am trying to process a large data set on our High Performance Computing Cluster - all steps have processed fine but when I get to the pre.cluster step, it seems to hang on and stall at processing a specific sample. I haven’t received an error and it has not updated files for over 8 days. I have tried running this process on 1.41.1 and 1.41.2. I have run this same script on other data sets and never had this issue before. I have tried it with different processors (1, 2, 8, and 48, 100) to see if that would influence the run - at the 48 and 100 processors, the process did “kill” itself.

pre.cluster(fasta=AmphStability.trim.contigs.good.unique.good.filter.unique.fasta, count=AmphStability.trim.contigs.good.unique.good.filter.count_table, diffs=4, processors=8)

I can share my data files if there might be an issue there.

Hi - can you try the latest version - 1.42.1? We made a few improvements that should speed things up and cause mothur to use less RAM.

Pat

Upgrading to 1.42.1 solved the issue - thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.