WindowsGUI problem


I’m trying to download and run the WindowsGUI on a 32 bit computer (Windows 8), and I get message when I launch the program. It says to contact you about the error.

“Cannot find C:\Window\System32\logfiles\mothur2-4-2014_14-42-9.GUI_logfile” or something very close to that.

What to do?


The mothurGUI creates a folder called logfiles in the same directory it is located in, and writes all its log files there. Did you move the mothurGUI.jar to C:\Window\System32? Perhaps the GUI cannot write to this location?

No, I didn’t.

After the first attempt, I removed it and re-extracted it from the zip file again. Same result. So, I tried redownloading it and extracting again. I got the same result.

I tried searching the computer for the logfile, but could not locate it. I can try that again to see where it might be.

Do I have to set the Path in the Windows Environment? I’ll check there and see if the path was incorrectly designated.

From your Download page:

We have compiled mothur v.1.33.3. We’re pretty sure that the 32bit executable should work for XP and Vista. The 32 bit version was built on Windows 7 and the 64bit version was built on Windows 8. Please let us know how this works for you:

So, if I am trying to instal the 32-bit version of mothurWinGUI onto a 32 bit computer running Windows 8, is that the source of my problem?

Problem solved! What had happened was a User (who did not have admin rights) had previously tried to launch the GUI on their machine in a location that they did not have “permission” to write files, ,so they abandoned the attempt. After extensively searching the computer, and removing anything related to the mothur program, restarting, and granting the user admin rights, I was able to successfully launch the program.

I honestly cannot say why this was a problem, but may be something in the Windows OS. So the 32-bit WinGUI program is now working fine on the Windows 8 Platform (as far as I can determine).

Glad it worked out, and thanks for posting the resolution.