mothur

Problems at the beginning

Hello,

I ran into problems immediately upon starting the program. I have the latest version (v.1.44.3) on my computer - the operating system is Windows 10. When I start the program, an error message immediately appears: “[ERROR]: Could not open mothur.1615667951.logfile” I tried deleting the previous logfiles, and I am the system administrator on my computer, but nothing worked, the logfile simply didn’t appear. I tried writing some commands, but the program immediately crashes and closes, I can’t even run the set.dir(debug=T) to get a clearer view on the problem. I tried to delete the program from the computer, and download it again, but nothing worked.
Can you help me with this problem?

Thank you very much in advance!

When mothur can’t open the logfile, it is most often caused by a permissions issue or a disk space problem. Do you have write permissions to the location of mothur’s executable? Does mothur have enough disk space to write the logfile?

Yes, I have the permission, and there is almost a hundred gigabytes free space on my disc, so it shouldn’t be a problem.

Excuse me, but do you have any other ideas for this problem? Or it might be with my computer? Thank you very much for the reply!

Could you try the following?

  1. Download the latest version of mothur, Release Version 1.45.0 · mothur/mothur · GitHub, and move mothur folder to your home directory.

  2. Open a command prompt and cd into the mothur folder in your home directory.

  3. From the command prompt, run the following:

    mothur “#help()”

  4. Send me a screenshot of the results

Thank you very much, I’ll send you as soon as possible!

Dear Sarah Westcott!
I’ll upload the screenshots I got (I’m a new user, so I will have to upload them one by one). Thank you very much in advance!

![2021-04-12 (3)|690x370]

I can see you have mothur installed and it is able to open and run the help command successfully. That’s great! Let’s try running Pat’s example analysis. Can you download the MiSeq_SOP files, https://mothur.s3.us-east-2.amazonaws.com/wiki/miseqsopdata.zip and reference files https://mothur.s3.us-east-2.amazonaws.com/wiki/silva.bacteria.zip and https://mothur.s3.us-east-2.amazonaws.com/wiki/trainset9_032012.pds.zip?

  1. Move all files to the same location you have mothur. Placing the reference files in the MiSeq_SOP folder.

  2. Run the stability.batch file in the MiSeq_SOP folder and post the results:

C:\Users\medva\Mothur.win\mothur>mothur “.\MiSeq_SOP\stability.batch”

One thing to note, we released a new version to resolve a bug. You can download it here, Release Version 1.45.2 · mothur/mothur · GitHub.