mothur

Vsearch in 1.42

#1

I tried to detect chimeras with the newest version of mothur on Windows, but got this error.

mothur > chimera.vsearch(fasta=current, count=current, dereplicate=t)

[ERROR]: vsearch version found = T,. Mothur requires version v2.11.1 which is distributed with mothur’s executable or available on github https://github.com/torognes/vsearch/releases/tag/v2.11.1, please correct.
[ERROR]: did not complete chimera.vsearch.

vsearch.exe is in the same folder as mothur.exe, so I’m not sure what’s wrong.

#2

Hi, I am getting the same error. However, using mothur 1.41.3 with vsearch 2.11.1 works ok. Hope it can be solved.

#3

Thanks for reporting this issue. The vsearch program changed their output file format in recent releases. We in turn modified mothur to work with the new format. To insure mothur is being run with the correct version of vsearch we added a version check. This check was not working correctly for the Windows version. I have corrected the issue and the uploaded a new Windows version to github. You can download it here, https://github.com/mothur/mothur/releases/tag/v1.42.0.

@lborras Version 1.41.3 does not include the version check or format modification. If you run 1.41.3 with version 2.11.1, you won’t see a version error but will see downstream commands hit a name mismatch. The output file format change causes a character to be removed from the sequence names. You can run version 1.41.3 with the older version of vsearch, 2.3.4, or upgrade mothur to version 1.42.0.

#4

Dear westcott,
Thank you very much for solving this issue. And thank you very much for your suggestions.
However, the new version of mothur (the one you updated today) introduces a new error: when using chimera.vsearch command, the following error message appears recurrently: “[ERROR]: M04376_266_000000000-C84N4_1_1112_22889_19583; is not in your count table. Please correct.”. Nevertheless, all those sequences are indeed in the .count-table file.
I have tried the mac version of mothur with the same samples and pipeline and it works perfectly. Hope this helps to resolve this issue.

#5

Hmm… I am not able to reproduce that error with my test data. Could you send your logfile and input files to mothur.bugs@gmail.com so I can take a closer look?

#6

Thanks for your help in tracking down this issue. The vsearch program is outputting slightly different results for its Windows and MAC versions. I have an issue open with vsearch support you can follow here, https://github.com/torognes/vsearch/issues/371. I will have a mothur update soon.

#7

Thank you very much!!

#8

I modified mothur to use vsearch version 2.13.3 which corrects the sequence name issue. You can download it here, https://github.com/mothur/mothur/releases/tag/v1.42.0.

#9

Now it works perfectly!!!

Thank you.

closed #10

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.