I’m received an error “[ERROR]: unable to spawn the necessary processes” when running the command

mothur > chimera.uchime(fasta=combined.unique.good.unique.precluster.align, name=combined.unique.good.unique.precluster.names, group=good.groups, processors=16)

I’ve checked fasta, name, and group files and am at a loss for what’s going on here. I’m running on a large server so processing power shouldn’t be the issue.

Thanks for any comments/suggestions

This error happens when the system command fork() fails. It fails when you run out of memory. Try running the command with less processors.

Thanks, that worked but only if I chose 1 processor. Any idea why this would be when all the prior commands have been able to function with 16 processors selected?

Also, now that I have gotten past the spawning error problem I received this message:

mothur > chimera.uchime(fasta=combined.unique.good.pick.pick.pick.unique.precluster.align, name=combined.unique.good.pick.pick.pick.unique.precluster.names, group=mergegroupsgoodpickpickpick, processors=1)

Using 1 processors.

uchime by Robert C. Edgar
This code is donated to the public domain.

Checking sequences from /home/bconroy/ZoopNGS1/combined.unique.good.pick.pick.pick.unique.precluster.align …
[ERROR]: Could not open /home/bconroy/ZoopNGS1/combined.unique.good.pick.pick.pick.unique.precluster.denovo.uchime.chimeras1

My PI is having the same error command, (the denovo one) which he’s never encountered. The only difference is we recently switched to v1.36 for Linux.

Thanks again for any help

How many sequences total? Did you run the chimera.uchime command as part of a batch or by itself?

~1.8 million. The initial error occurred when I was running a batch. Since that error I have been running chimera.uchime by itself with only the 1 processor option. That gets me through without the spawn error but subsequently having the denovo file error.


Whats the “denovo” error?

Checking sequences from /home/bconroy/ZoopNGS1/combined.unique.good.pick.pick.pick.unique.precluster.align …
[ERROR]: Could not open /home/bconroy/ZoopNGS1/combined.unique.good.pick.pick.pick.unique.precluster.denovo.uchime.chimeras1

We seem to identified it as a bug with the Linux version although not sure what the bug is. I’m currently running it on a windows machine and didn’t encounter the spawning error even with 16 processors and so far none of the other errors have occurred either. My collaborator was also able to get through the file opening error in the mac version. So not sure what the problem is but have at least gotten a step further now.

Thanks for all the help and if you have any other suggestions I’m happy to try them.

Does the linux machine have less memory?