chimera error


I was trying to run the chimera check with batch mode and after few samples it got killed/stopped.
with the following error;

Job 5226960 (chime_self) Aborted
Exit Status = 137
Signal = KILL
User = sraju
Max vmem = 83.159G
failed assumedly after job because:
job 5226960.1 died through signal KILL (9)

then I tried in the command line and the command got killed even before checking few samples.

mothur > chimera.slayer(fasta=batch1.trim.contigs.good.unique.good.filter.unique.precluster.fasta, count=batch1.trim.contigs.good.unique.good.filter.unique.precluster.count_table, processors=50, reference=self)

Using 50 processors.
Checking sequences from batch1.trim.contigs.good.unique.good.filter.unique.precluster.fasta …
[sraju@mars Batch1_mothur]$

I have tried it with processors=1 also still the same error occurred.

Can any one tell me, what would be the problem here? :?:


It appears to be a memory issue. Have you tried using the chimera.uchime command?

Yes. I have tried with uchime command also. With one and more processors. I have assigned more memory (1Tb) in my analysis. So what would be other possibilities here?

Can you run summary.seqs with the files? That would rule out any type of file format issue. How many sequences are in your dataset? What version of mothur are you running?

it seems the chimera.uchime command is working now. I will let you know if stop working.

chimera.uchime(fasta=batch1.trim.contigs.good.unique.good.filter.unique.precluster.fasta, count=batch1.trim.contigs.good.unique.good.filter.unique.precluster.count_table, dereplicate=t, processors=1)

I am using the mothur Version 1.35.1. And I have 1028639 sequences in the batch1.trim.contigs.good.unique.good.filter.unique.precluster.pick.summary.

Thanks Sarah. :slight_smile:


Again it got aborted with the same error and its not showing any error in logfile.

here is the summary.seqs results;

summary.seqs(fasta=batch1.trim.contigs.good.unique.good.filter.unique.precluster.pick.fasta, count=batch1.trim.contigs.good.unique.good.filter.unique.precluster.count_table, processors=100)

Using 100 processors.

                Start   End     NBases  Ambigs  Polymer NumSeqs
Minimum:        1       943     372     0       3       1
2.5%-tile:      1       943     403     0       4       754082
25%-tile:       1       943     422     0       4       7540815
Median:         1       943     427     0       4       15081630
75%-tile:       1       943     427     0       5       22622445
97.5%-tile:     3       943     427     0       8       29409178
Maximum:        3       943     427     0       8       30163259
Mean:   0.902792        851.33  380.871 0       3.87307
# of unique seqs:       1028638
total # of seqs:        30163259

can you guess anything from this?
I am using the mothur Version 1.35.1.


The uchime program is failing due to a memory issue, but you will face issues downstream. Pat has written a blog post with his thoughts on the issue,