Chimera.uchime command not working

I’m using mothur v.1.42.0 and I was running command chimera.uchime as follows:
mothur> chimera.uchime(fasta=/home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.fasta, count=/home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.count_table, dereplicate=T)

Using 1 processors.
and I got the following error: [ERROR]: /home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.fasta is blank. Please correct.

00:00 31Mb 0.1% Reading /home/heba/New/fileList.paired.trim.contigs.good.uni00:00 31Mb 0.1% Reading /home/heba/New/fileList.paired.trim.contigs.good.uni00:00 31Mb 100.0% Reading /home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.temp
Floating point exception (core dumped)
[ERROR]: /home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.denovo.uchime.chimeras is blank. Please correct.

It took 0 secs to check 0 sequences. 0 chimeras were found.

Output File Names:

Can you help me find chimeras in my sequences?
I also tried dereplicate=F and not adding the dereplicate parameter, and I got the same outcome.

Thank you!

Can you post the output of what you get when you run…

summary.seqs(fasta=/home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.fasta, count=/home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.count_table)

This is what happened:
mothur > summary.seqs(fasta=/home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.fasta, count=/home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.count_table)
[ERROR]: /home/heba/New/fileList.paired.trim.contigs.good.unique.filter.precluster.fasta is blank, aborting.
You have no current fastafile and the fasta parameter is required.

Using 1 processors.
[ERROR]: did not complete summary.seqs.

I checked and the precluster.fasta is blank, while all other fasta files (good fasta and unique fasta) are normal and include sequences!

Can you post the output from when you do the following?


You might also post the output of what you did when you ran screen.seqs and the output from


This is the output of the first command:

mothur > summary.seqs(fasta=/home/heba/fileList.paired.trim.contigs.good.unique.fasta)

Using 1 processors.

		Start	End	NBases	Ambigs	Polymer	NumSeqs
Minimum:	1	35	35	0	3	1
2.5%-tile:	1	439	439	0	4	6201
25%-tile:	1	443	443	0	5	62009
Median: 	1	460	460	0	5	124018
75%-tile:	1	460	460	0	6	186027
97.5%-tile:	1	465	465	0	6	241835
Maximum:	1	470	470	0	8	248035
Mean:	1	452.215	452.215	0	5.19994
number of Seqs:	248035

Output File Names: 

It took 4 secs to summarize 248035 sequences.

I didn’t find a fle named /home/heba/New/fileList.paired.trim.contigs.align but I ran the command using "/home/heba/New/fileList.paired.trim.contigs.good.unique.align
and here is its output:

mothur > summary.seqs(fasta=/home/heba/fileList.paired.trim.contigs.good.unique.align)

Using 1 processors.

		Start	End	NBases	Ambigs	Polymer	NumSeqs
Minimum:	1	1231	1	0	1	1
2.5%-tile:	        1	13422	290	0	3	6201
25%-tile:	        1	13422	290	0	4	62009
Median:  	       1	13422	291	0	4	124018
75%-tile:	       1	13422	291	0	5	186027
97.5%-tile:      1	13422	292	0	6	241835
Maximum:	13425	13425	301	0	8	248035
Mean:	65.6023	13419.1	289.425	0	4.23962
number of Seqs:	248035

Output File Names: 

It took 80 secs to summarize 248035 sequences.

It looks like you probably didn’t run screen.seqs, right? You’ll want to run something like this before running filter.seqs, unique.seqs, pre.cluster, and then chimera.uchime

screen.seqs(fasta=fileList.paired.trim.contigs.good.unique.align, count=fileList.paired.trim.contigs.good.count_table, start=1, end=13422)
filter.seqs(fasta=current, vertical=T, trump=.)
unique.seqs(fasta=current, count=current)
pre.cluster(fasta=current, count=current, diffs=2)
1 Like

I have precisely run these commands again and these are the outputs of them;
I ran the first command screen.seqs(fasta=fileList.paired.trim.contigs.good.unique.align, count=fileList.paired.trim.contigs.good.count_table, start=1, end=13422)
and this was the output of it:

then the second command filter.seqs(fasta=current, vertical=T, trump=.)
and this was the output of it:

When I ran the third command unique.seqs(fasta=current, count=current)
this happened:

I opened the count table file and removed the extra specified sequence and then ran the same command again,and this was the output:

the 4th command pre.cluster(fasta=current, count=current, diffs=2)
and this was its output:

and when I ran the uchime command this was the output.

Thanks a lot for your patience! :slight_smile:
Can I know how to get a file named “stability.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.pick.count_table” from the uchime/vsearch command to run the following command:
classify.seqs(fasta=stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.fasta, count=stability.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.pick.count_table, reference=trainset9_032012.pds.fasta,, cutoff=80)
as I couldn’t run the command due to the missing input file
Thank you.

You will most likely never get a file that is beginning with stability. It is just the name of the file that they used in the Mothur SOP. So whatever your file name is, in this case “fileList”, will be the beginning of all the files that you get as output.

To help you, not only the output is interesting but also the input. Most of the commands can be run in a lot of different ways. Did you provide a count_table file when running the chimera.vsearch? Because normally you then should get a “.denovo.vsearch.pick.count_table”

I encourage you to thoroughly check if you used exactly the input that they use in the Mothur SOP. Most of the errors or missing files are based on that.


Thank you, it’s a typo as I copied and pasted the exact command from the MiSeq SOP, but of course I use my own file, in fact I drag and put them in the terminal, so I used the “fileList” one.
Regarding your question, yes I provided a “FileList.trim.contigs.good.unique.good.filter.unique.precluster.count_table” table when running the chimera.uchime command, but I only got the “chimeras” and “accnos” files and not a pick.count_table file. I checked and repeated the process many times exactly like the Mothur SOP, but I get stuck in this step everytime.

Thanks a lot for your help.

Did you set the dereplicate parameter? You only get a modified count file from the chimera commands if you run the commands with dereplicate=t. If the dereplicate parameter is false (default=false), then if one group finds the sequence to be chimeric, then all groups find it to be chimeric and the read is added to the accnos file for removal. If you set dereplicate=t, then samples where the sequences are found to be chimeric have their totals adjusted to reflect the removal of the bad reads, but the read is not added to the accnos file unless all samples find it to be chimeric. Because the adjustments are persample, mothur outputs a modified count table. Does this clear things up?

Hi. I am having the same problem as HebaAttia while following the MiSeq SOP protocol. I run chimera.vsearch

chimera.vsearch(fasta=16s.trim.contigs.good.unique.good.filter.unique.precluster.fasta, count=16s.trim.contigs.good.unique.good.filter.unique.precluster.count_table, dereplicate=t)

and only get two output files: 16s.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.chimeras


Do you know why my output does not include the count_table I need in the following steps? Thanks for your help!

Hi @laurolon, I added a mergegroup file to my analysis and when I ran the chimera.uchime command again, it went just fine and I got the count table output I was looking for.
The command for getting a mergegroup file is ", groups=A-B-C)".
THen use the output file which will be “mergegroups” as an group input file in this count.seqs command “count.seqs(name=stability.trim.contigs.good.names, group=stability.contigs.good.groups”
Try it, it made my analysis steps way easier and smoother.

@laurolon, what version of mothur are you running? Could you post the full log file?