I was wondering what the count_table file does in the chimera.uchime and if it is necessary?

Thank you!

The count table is used to when you want to use your dataset as a reference for chimera checking. Mothur uses the more abundant sequences in each sample as the reference for checking the less abundant sequences. If you set dereplicate=t, mothur will also create a new *pick.uchime.count_table.

Okay thanks!.. So I do not need to provide the a count table when running chimera.uchime if using dereplicate=t ?

Nope, the opposite. You do need to provide one. If you are using the your dataset as a reference you need to provide a names and group file or count file. Mothur uses those files to find the more abundant sequences and divide the sequences into samples.

This is regarding an error message in chimera.uchime that I keep getting.
I am following the MiSeq SOP closely. I’m using 1.32.1 version.
This is the error that I get when I run chimera.uchime:

othur > chimera.uchime(fasta=current, count=current, dereplicate=t)
Using stability.trim.contigs.good.unique.good.filter.unique.precluster.count_table as input file for the count parameter.
Using stability.trim.contigs.good.unique.good.filter.unique.precluster.fasta as input file for the fasta parameter.

Using 40 processors.

uchime by Robert C. Edgar
This code is donated to the public domain.

Checking sequences from stability.trim.contigs.good.unique.good.filter.unique.precluster.fasta …
[ERROR]: Could not open stability.trim.contigs.good.unique.good.filter.unique.precluster.uchime.chimeras59316.tempApril_DNA
[ERROR]: Could not open stability.trim.contigs.good.unique.good.filter.unique.precluster.uchime.chimeras59325.tempJuly_DNA

I assume it means that it sees the file as empty??
I have tried to run this a couple of times with the same result. Do I need to go back into my folder and delete the temp files it creates before trying again? would that help?

Mothur creates the temp files when running the commands with multiple processors. Could you try it with processors=1? If that does not resolve the issue, can you send your files to and I will try to troubleshoot it for you?

Hi all,

I’m new here and following the MiSeq SOP using version 1.33.3
All previous commands worked well for my data, but now I’ve got a problem with the chimera.uchime command…

My dataset contains around 2 million sequences (quite many…) and I started using 12 processors
mothur > chimera.uchime(fasta=stability.files.trim.contigs.good.unique.good.filter.unique.precluster.fasta, count=stability.files.trim.contigs.good.unique.good.filter.unique.precluster.count_table, dereplicate=t, processors=12)
At first this worked fine, but then I noticed that my computer was only using 6 processors and right now it’s down to only 1 processor and that really takes forever…has this problem ever occured before?
Also mothur generates many .temp files, is there a way to see which groups are already finished and on which groups the command is still running? Would it then be possible to start chimera.uchime again, using only those groups which were not finished before, or would this cancel the whole process?


You likely have one sample that is huge and so it is taking awhile. I’d just say to be patient. Also, do you have 2 mil unique sequences going into uchime or 2 mil total sequences? If it’s uniques you should be prepared to not do OTUs since it won’t work. We generally see this large number of uniques when people no not sequence regions with fully overlapping reads and so they cannot get adequate denoising of their data.