summary.seq issues with missing names in .name file


I am trying to run a summary.seqs command using a fasta and names file and I’m getting the error that two of the names that are present in the fasta file are not in the names file. However, when I check my names file and search for those names, the names are present. Hence, I can’t do a proper summary.seqs to look at the number of unique seqs and all seqs. If I run the summary.seqs without the names file, Mothur picks up the same file I used previously as the matching names file, and spits out a summary table. How do I deal with names that are actually present in my names file, but Mothur can’t seem to recognise as being present?

Ex: summary.seqs(fasta=allenv.groups.fasta, name=allenv.groups.names, processors=2)

[ERROR]: ‘barcode=env2PL19D;IWNQ2AP01EIZI7’ is not in your name or count file, please correct.
[ERROR]: ‘barcode=env1ES00;IQMYI5B02GWM4F’ is not in your name or count file, please correct.

If I run:
summary.seqs(fasta=allenv.groups.fasta, processors=2),

I get a summary output and Mothur will use name=allenv.groups.names as a namefile it can take to match my fasta file, but not seem to have issues with this.

Thanks in advance for help.

I looked back at an old file for a different run and it seems that I don’t have the names file in the correct format.

I have the ‘IWNQ2AP01EIZI7’ and ‘IQMYI5B02GWM4F’ in my names file, but not ‘barcode=env2PL19D;IWNQ2AP01EIZI7’ or ‘barcode=env1ES00;IQMYI5B02GWM4F’ in the actual names file. Hence the error.

So you have it worked out? It looks like there might actually be a problem with your oligos file.


Yep, got it figured out. The names file did not have the correct names as I added extra information to the names of the seqs, but I hadn’t updated my names file. Got an updated names file using the unique.seqs (fasta=file.fasta). Thanks!