Segmentation fault on Ubuntu 10.04 LTS

Hi, mothur developers,

I’ve got a segmentation fault when I run screen.seqs() command on a fasta format file aligned using silva.bacteria.fasta reference template. The error messages are at the end. Interesting, When I run screen.seqs() command with the aligned fasta file generated by align.seqs() using greengene reference template, the command finished without any error message. My computer’s CPUs are Intel Xeon processors and the OS is Ubuntu 10.04 LTS. Have you guys seen similar problems?

mothur > screen.seqs(fasta=dataset.align, minlength=120)

[zeb:11172] *** Process received signal ***
[zebt:11172] Signal: Segmentation fault (11)
[zeb:11172] Signal code: Address not mapped (1)
[zeb:11172] Failing at address: 0x11d0000
[zeb:11172] [ 0] /lib/ [0x7f94c0fab8f0]
[zeb:11172] [ 1] /lib/ [0x7f94c0ca003b]
[zeb:11172] [ 2] mothur(_ZN17ScreenSeqsCommand9driverMPIEiiRP11ompi_file_tS2_S2_RSt6vectorIySaIyEERSt3setISsSt4lessISsESaISsEE+0x103) [0xaf59a3]
[zeb:11172] [ 3] mothur(_ZN17ScreenSeqsCommand7executeEv+0xdfb) [0xaff06b]
[zeb:11172] [ 4] mothur(_ZN14InteractEngine8getInputEv+0x7f3) [0x75cc13]
[zeb:11172] [ 5] mothur(main+0x119c) [0x934cac]
[zeb:11172] [ 6] /lib/ [0x7f94c0c37c4d]
[zeb:11172] [ 7] mothur() [0x489569]
[zeb:11172] *** End of error message ***
Segmentation fault

Thanks for bringing this to our attention. It is a bug with our MPI version of screen.seqs. I have fixed the issue and uploaded a new copy of the 1.26.0 source to the wiki.