v. 1.13.0 screen.seqs seg fault

Hi all,

I’m running the 32-bit version of mothur 1.13.0 on Ubuntu 10.04 (Lucid) with readline and MPI support compiled.

I get a segmentation fault when I run screen.seqs on a fasta file.

mothur > screen.seqs(fasta=3.pick.align, start=22000, end=28000, minlength=230)

[cthulhu:08641] *** Process received signal ***
[cthulhu:08641] Signal: Segmentation fault (11)
[cthulhu:08641] Signal code: Address not mapped (1)
[cthulhu:08641] Failing at address: 0xfffffffc
[cthulhu:08641] [ 0] [0x671410]
[cthulhu:08641] [ 1] mothur(_ZN17ScreenSeqsCommand7executeEv+0x1077) [0x83bdf17]
[cthulhu:08641] [ 2] mothur(_ZN14InteractEngine8getInputEv+0x508) [0x81eee68]
[cthulhu:08641] [ 3] mothur(main+0x1236) [0x82e5d76]
[cthulhu:08641] [ 4] /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x6f6bd6]
[cthulhu:08641] [ 5] mothur() [0x8091921]
[cthulhu:08641] *** End of error message ***
Segmentation fault

I have no problem with this when I run screen.seqs on version 1.9.
The fasta file “3.pick.align” has 20,407 sequences aligned to the SILVA db and is still 5.6 MB when gzipped, otherwise I’d attach it to see if this is reproducible.
I can send it via email if you’re curious to try.

Any ideas?

Thanks,
-Chris

Oops - duplicate bug: