mothur annoyances

A couple of small things have been bugging me about mothur. None have been serious enough to warrant having their own thread, but I think they’ve just about achieved critical mass for posting. Some are new to Mothur 12. Some have been around for a while.

  1. Get.oturep leaves *.names.temp files under Windows version 12. No biggie. We just delete them.

  2. This sequence of commands will always crash mothur (linux or windows)):


#error message thrown


Somehow, the error message (trying to calculate single mode estimators while in shared mode) leaves the system volatile so when the correct command is keyed in, it crashes. Again no biggie. Restart mothur and continue where you left off.

  1. Classify.seqs should append the method used to the output file names. That way, you won’t accidentally clobber your output if you use different methods for, say, phylotype analysis and classifying otu. But then, mothur should never ever ever clobber files without asking the user’s permission anyway…

  2. Similarly for Venn diagram output. The group names should be appended to the output file names so as to mitigate mothur’s clobbermania.

  3. The read.tree command needs a name= option. This will decrease the size of my mothur log file by 1/2 as there wont be any
    “XXX is in your groupfile and not in your tree. It will be disregarded.” messages in it.

  4. Classify.otu doesn’t really seem to “get” the name option. Or at least, not completely. Or else it wouldn’t fill the other 1/2 of my log file with: “XXX is not in your taxonomy file. I will not include it in the consensus.”

  5. get.sharedseqs should take a shared= option. Not that it takes that long to recalculate the shared data from the list and group files, but if the shared file exists anyway, why not use it? Less typing AND it makes for a more consistent user experience.

  6. Mothur will switch into single-mode after a shared analysis. Try this:


will pump out individual collector curves for EACH of your groups. But then type:


and mothur will generate the rarefaction curve for ONLY the last group. But wait! Now do this:


and mothur will generate the rarefaction curves for EACH of your groups. But then type:


and mothur will generate the collector curves for ONLY the last of your groups. Funky, no?

  1. On the Windows version of Mothur 12, the confidence interval code for shared analysis is incomplete. It works fine for the Linux version. This wouldn’t be a huge deal except that Mothur creates 12 columns of header information and only 4 columns of actual numbers… which borks my R scripts for generating plots. Temporary fixes: a) fix my R code b) delete the heading info c) use an older version of mothur d) use the Linux version or e) wait for the next version of mothur.

  2. Some of these things would be almost as fast for me to fix as they are to whine about. Casual contributions to coding mothur would be greatly facilitated by setting up either a SVN or CVS system.

Congrats on getting mothur this far. I’m only hard on ya coz I love ya :wink:


Thanks for bringing this list to our attention. We are going to release a 1.12.1 later today to fix a few bugs in 1.12.0, and many of these items will be included in that.

1, 2, and 8 are fixed.

3 & 4. We would rather not ask the user before we overwrite files, since many of our users run mothur in script or batch mode and the scripts would be held up waiting for permission from the user. We are going to work on the “gangly” file names. For classify.seqs the output file name will become yourFastaFile.simplifiedTaxName.taxonomy, and the venn diagram names will become inputFileName.label.calc.groups.svg

  1. Read.tree has a name option. It was added in version 1.9, but the wiki docs did not get modified to show how to use it. Sorry about that.

  2. I think you may have been using a unique taxonomy file with a list file containing all the sequences. Mothur was assuming the list file only contained the uniques. We have changed the classify.otu command to assume the list file contains all the sequences. Feel free to send your files to if I am making a bad assumption here. Thanks.

  3. The get.sharedseqs command needs the sequence names, and the shared file just contains the rabund data.

  4. I am not sure what you mean here.

  5. Code contributions are always welcome and we are working on making it easier to do so.

Thanks again for helping us improve mothur!


  1. Still not fixed. Sorry. :frowning:

  2. Confirmed fixed. thanks.

  3. it seems all you’ve done is shortened the file name.
    It WAS
    and is now something.silva.taxonomy
    and I want something.silva.kmer.taxonomy

  4. Confirmed fixed. Awesome! Thanks.

  5. Aha! thanks for the mothur lesson.

  6. Yes! Fixed! Thanks!

  7. Ok I guess that makes sense.

  8. Confirmed fixed. Thanks!

  9. Whether or not you understood my issue, it’s fixed. Thanks!

  10. I hope that you’re hinting at a version control system, coz shooting code back and forth by e-mail is a very 1980’s way of doing collaborative software dev :stuck_out_tongue: