metastats outputting negative q-values?

I’ve been happily using mothur for about half a year now without any serious problems, but now I ran into something quite weird. I’m running metastats for phylotype-based shared-files of my 16S dataset on different taxonomical levels. I’ve already done this several times with different groupings (different design-files). Now, on the results of one metastats run (specifically, a Phylum-level one), all the q-values are negative. Of course, this makes no sense whatsoever. I tried running it again, and got a similar result file. Has anyone seen this before? Any idea what might be going on?

To add to the above, I just tried running the same file through the online version of metastats on their website, and that resulted in a q-value of 1 for each row. I guess there’s something wrong about my file, and I should be in touch with the metastats people about it if I really want to figure this out.

We found a bug in mothur’s version of metastats. Mothur was reporting the permutted pvalues for sparse data instead of using the fisher’s exact test. This can cause negative qvalues. It will be fixed in our release later this week.