make.file warning: unable to find any fastq files in your directory

I’m using Mothur 1.37.4 on a Windows 64-bit PC. I set the input directory to a folder called “sample 01”, and I used “get.current” command to confirm it.

I tried to use “make.file” command to generate a “files” file, but it didn’t work. Mothur kept sending me warning messages: “file not found-”*fastq". Unable to find any fastq files in your directory." It’s interesting that when I use “”, Mothur can read those fastq files, but only one at a time.

Please help me solve this problem. Thanks!!!

Could you run the command in debug mode and post the results?

mothur > set.dir(input=yourInputDirectory, debug=t)
mothur > make.file(…)

Here are the results:

"mothur > make.file(inputdir=C:\Users\Missi.HICHNER296\Desktop\sample01)

[DEBUG]: removed C:\Users\Missi.HICHNER296\Desktop\sample01\temp1470764249
[DEBUG]: removed C:\Users\Missi.HICHNER296\Desktop\sample01\temp1470764249
Setting input directory to: C:\Users\Missi.HICHNER296\Desktop\sample01
[DEBUG]: removed C:\Users\Missi.HICHNER296\Desktop\sample01\temp1470764249
find “C:\Users\Missi.HICHNER296\Desktop\sample01” -maxdepth 1 -name “.fastq" > “C:\Users\Missi.HICHNER296\Desktop\sample01\fileList.temp”
File not found - "
[DEBUG]: removed C:\Users\Missi.HICHNER296\Desktop\sample01\fileList.temp
[WARNING]: Unable to find any fastq files in your directory.

Output File Names:"

Thank you!

Is the name of the directory C:\Users\Missi.HICHNER296\Desktop\sample01 or C:\Users\Missi.HICHNER296\Desktop\sample 01 with a space?

Sample01, no space

I’m having this exact same problem with .gz files.