make.file problem

When running through the MiSeq SOP tutorial, I try to run the make file command:

make.file(inputdir=MiSeq_SOP, type=fastq, prefix=stability)

And am greeted with this message:

MiSeq_SOP directory does not exist or is not writable
MiSeq_SOP directory does not exist or is not writable
[ERROR]: did not complete make.file.

Now I know that I have the mothur executable file in right place and that it can read from the directory since I can check this with the get.current command and have run the entire rest of the MiSeq_SOP tutorial with the pre-made stability.file and had no problems; it just seems to be the make.file command that wont execute.

I’m using the most recent version of mothur and no one else seems to have quite this same problem. Suggestions?

First rule in computing and realestate. location, location, location. What is your working directory? where is the folder that you’re telling mothur to look for?

Hi, since posting I’ve been told that although keeping the mothur executable file in the MiSeq_SOP directory with the fastq works for all the other commands, it wont work for the make.file command. So I moved the executable file out one directory; this got rid of my original message but instead now I get this:

MiSeq_SOP\ directory does not exist or is not writeable.
‘ls’ is not recognized as an internal or external command, operable program or batch file.
[WARNING]: unable to find any fastq files in your directory.

This feels like progress as I noticed somebody else on the forum posted with the same error; however, the response to this was simply:

“you need to type: system(ls)”

I’ve tried this in multiple ways but it doesn’t seem to be a recognized command.


are you in the MiSeq_SOP folder? Is it spelled correctly, including caps? Before you type “mothur” to launch the program, type “ls” to see what is in the folder. Conversely once you have mothur running you can use system(ls) to see the contents of your working directory.

Hi kmitchell,

Yep, I’m in the MiSeq_SOP folder, everything is spelt correctly and mothur has no problem accessing the directory for other commands. But I’m clearly missing something with this ls and system(ls) stuff. These aren’t things that are accepted when I type them into mothur. Are you saying there’s a place to type commands before mothur is actually running? I’ve never had to type mothur to start it up, I just click on the executable file to run it.


We had a bug with the make.file command for Windows. Could you try downloading our latest version,

Works like a charm now.

Cheers and thanks

I’m having the same problem and I have the latest version downloaded today (1.39.4 for windows).

MiSeq_SOP directory does not exist or is not writable
MiSeq_SOP directory does not exist or is not writable
[ERROR]: did not complete make.file.

When I move mothur out of the MiSeq_SOP folder so it’s in MiSeqSOPData, it says:

Setting input directory to: MiSeq_SOP\

and then mothur crashes.

I’m trying to follow through the Miseq SOP so all folders were extracted and put into the MiSeq_SOP folder as outlined in the SOP. I copied and pasted the first command and it is all spelled correctly. I also just click on the mothur executable to run it. Advice is greatly appreciated as I’ll need to make.file for my own data.