make.contigs Error


I’ve just started using Mothur (using the MiSeq_SOP) and I’ve hit a wall at one of the first steps.

Entering make.contig(file=stability.files, processors=4) gives me an Error message that the file cannot be found in the directory.

This happens with the Mothur executable in the same folder as the stability.files file (and all fastq files).

A thorough googling has found a few approaches to fixing the problem, but none have worked.

One last piece of information: I tried opening the stability.files file in NotePad (to see what was in it), which deleted the .files part of the file name, and the icon changed to the NotePad icon. I set the default program to open the file to Mothur, and re-added the .files to the name. I also tried deleting the whole batch of files and redownloading them, and the stability.files was automatically changed to stability. I’m not sure if any of this even matters, but just in case.

Thanks for the help,

After a few hours of trial and error, and seconds after posting to the board, I solved it myself.

system(dir) showed that by re-adding the .files to the name, it was really being renamed to stability.files.files. Deleting the second .files was the fix.

Hi there!!

Im sorry but I see you resolve a problem by yourself and I have a problem trying to analyze the same data as you did (MiSeq_SOP).

I try the first step with the command make.file and the program responses:

“Ls” is not recognized as an internal or external command, program or executable batch file. Unable to find any fastq files in your directory.

Do you know what would be happen here? I have the same error trying to make a file with the data MiSeq_SOP and with my data as well.

Thank you very much in advance.


You need to type


at the mothur prompt.