Make.contigs with gz not working

Hello all,

I just got the 1.48.0 installed last week in the server at ASU (Agave; SLURM queue manager).

I had a problem with make.contigs. I pass make.file with gz with no problem, but then make.contigs crashes the system.


Linux version

Using ReadLine
mothur v.1.48.0
Last updated: 5/20/22
Patrick D. Schloss

Department of Microbiology & Immunology

University of Michigan

When using, please cite:
Schloss, P.D., et al., Introducing mothur: Open-source, platform-independent, community-supported software for describing and comparing microbial communities. Appl Environ Microbiol, 2009. 75(23):7537-41.

Distributed under the GNU General Public License

Type ‘help()’ for information on the commands that are available

For questions and analysis support, please visit our forum at

Type ‘quit()’ to exit program

[NOTE]: Setting random seed to 19760620.

Batch Mode

mothur > make.file(inputdir=./, type=gz)
Setting input directories to:

Output File Names:

Error file:
/var/spool/slurmd/job17740685/slurm_script: line 14: 29838 Segmentation fault mothur

Code run:

make.file(inputdir=./, type=gz)
make.contigs(file=current, deltaq=10, insert=30, trimoverlap=T, processors=10)

If I decompress all gz files to fastq (and removing that part in make.file), it runs like a charm. So, something is going on (I think) with the gz step. Tried also forcing to 1 processor only (just in case) and same result. Also tried running it in interactive mode (just in case was something with the batch file) and same - gz files crash the make.contigs.



Hi Leo- You will need to have the Boost libraries installed to use type=gz. It doesn’t look like your version of mothur was compiled with Boost.


1 Like

Thanks Pat!

I will pass the message to the ASU team. Since this is a Uni resource, I am not in charge of compiling/updates, etc. I had a previous problem with vsearch (it was not there), but that one I was able to identify the problem myself (and they corrected it with no problem).


Hi Leo,

You could always use conda to install the latest version of mothur to install it within your account or grab the binary from our github release page.


Well, my idea was (is) starting to use mothur when teaching in class (now that I have teaching duties) so I would prefer if it is up and running in the server for the student to use, instead of making them install it in their partition.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.