File mismatch detected after align.seqs or screen.seqs

Hello, I’ve seen the topic of file mismatch opened on this forum multiple times, but have not seen a solution to my issue.

I have V4 region 16S sequences, and I’m using the silva v148.1 reference alignment. After cleaning up my sequences (using the SOP until the alignment point), and running align.seqs, mothur says the sequences are aligns and outputs three files: .align, .align_report, and .flip.accnos. When I go to run summary.seqs as my next step however, it gives me an error, saying file mismatch detected, quitting command. I don’t understand why align.seqs isn’t outputting a count_table? Or maybe it’s not supposed to? However, if you need any clarifications or additional information, please let me know.

I tried to solve this problem by doing:


get.seqs(accnos=output from the above command, count=x.count_table)

This solution worked to get summary.seqs working. Then I did screen.seqs and the file mismatch occured again after that because again a count_table was not generated. By solving the problem again with the above solution, problems were created down the line, so I don’t know if this is an adequate solution.

I completely restarted, deleting all previous files output by mothur, and tried again from the very beginning. When I did align.seqs again, I made sure flip=t even though I know that’s supposed to be the default. I then did summary.seqs and it gave me an output without using a count parameter. So then I did screen.seqs and it outputted a new fasta file (.align) and a new count_table. But, when I try to do summary.seqs, it says file mismatch detected, quitting command.

Thank you for any guidance!


It’s a bit confusing for me to follow what you’re trying to do. align.seqs does not output a count file since it doesn’t remove any sequences. You’ll want to use the last count file that you generated in your pipeline with the align file output from align.seqs to carry the pipeline forward. You shouldn’t need to use list.seqs or get.seqs and it’s unlikely you need to worry about the flip argument.

If you want to post the specific commands with file names that you are trying to run I can take a better look.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.