mothur

Error message on make.contigs in 1.43.0

This looks like an unzipping error? no issue when I run it using 1.39.5

mothur > make.contigs(file=project.file, processors=32)

Using 32 processors.

>>>>>   Processing file pair fastq/11033CLWHITE.Remiszewski111033CLWHITE_S98_L001_R1_001.fastq.gz - fastq/11033CLWHITE.Remiszewski111033CLWHITE_S98_L001_R2_001.fastq.gz (files 1 of 25)        <<<<<
Making contigs...
[WARNING]: reading ^_<8B>^H^D^@^@^@^@^@ expected a name with @ as a leading character, ignoring read.
[WARNING]: reading ^W9<B1>V^D@P<96><AA><E8><EE><AE><EA><CC>NE:E^P^@/2~G^D<EE><FD> expected a name with + as a leading character, ignoring.[WARNING]: names do not match. read ^_<8B>^H^D^@^@^@^@^@ for fasta and ^W9<B1>V^D@P<96><AA><E8><EE><AE><EA><CC>NE:E^P^@/2~G^D<EE><FD> for quality, ignoring.[WARNING]: Lengths do not match for sequence ^_<8B>^H^D^@^@^@^@^@. Read 38 characters for fasta and 13 characters for quality scores, ignoring read.[ERROR]: finding negative quality scores, do you have the right format selected? http://en.wikipedia.org/wiki/FASTQ_format#Encoding 
[WARNING]: reading ^_<8B>^H^D^@^@^@^@^@ expected a name with @ as a leading character, ignoring read.
[WARNING]: reading F<CE>z<BF>%<B0>#*<A2><DA>Y<9D><DD>]<95>^U<8A><B0>-<B0>><AF>^?-<F5> expected a name with + as a leading character, ignoring.[WARNING]: names do not match. read ^_<8B>^H^D^@^@^@^@^@ for fasta and F<CE>z<BF>%<B0>#*<A2><DA>Y<9D><DD>]<95>^U<8A><B0>-<B0>><AF>^?-
<F5> for quality, ignoring.[WARNING]: Lengths do not match for sequence ^_<8B>^H^D^@^@^@^@^@. Read 37 characters for fasta and 12 characters for quality scores, ignoring read.[ERROR]: finding negative quality scores, do you have the right format selected? http://en.wikipedia.org/wiki/FASTQ_format#Encoding 
^E2Tk@<B3><CC><CC>Z$<BE><99><E7>He^O<8E> is in your forward fastq file and not in your reverse file, please remove it using the remove.seqs command before proceeding.
^R<E7>-ESC<CF>O;gL<BD><AA>M=S<C2>h<FB>fQN_<B3><D4>,j<AC>d##<C8>^S^V8<E8><B4>j<A3>^]^A<C5>nФXxCA<AE><F4>-<B8>X<95><F9><EE><88>B"<86><A4><C8>^_gc<AD><B9>0(-<EF><E6>P<B2><F0>^_2<D0>V^F
<80>fv<D4>@<F5>\<BB>0^OG5<D0><E5>t!^C]<BA><AF>^Ee<9F>^@<C8>{^B<C8>;<FC>^H_<E4><ED>n<A4><A3>
<F3><AA>{Z<B7><C1>kg<99><BD>(a<F1>l<9A><B0>M is in your forward fastq file and not in your reverse file, please remove it using the remove.seqs command before proceeding.
^Z! is in your forward fastq file and not in your reverse file, please remove it using the remove.seqs command before proceeding.
^]^F;<95>'^@^Y^E^B<88>c<CB>_ѓ<8F><B6>^R@̅>^_ is in your forward fastq file and not in your reverse file, please remove it using the remove.seqs command before proceeding.
6<A7>?^D@^@·^@<C2>s<DF>^G<90><BC>^_.Ө<E9>0<E3>^N^W<CA><D0>^Aa3<A7>fq<92>2<U+D7F1><BE>\
<U+0519><9E>^N<84>׀<95>50<BE>G<ED><97>^YȻYU*M)TY5)0I}t<93>^B<88> is in your forward fastq file and not in your reverse file, please remove it using the remove.seqs command before proceeding.

Pat or Sarah? Ideas on what might be broken in make.contigs on .gz files with 1.43.0? I’m running this on a cluster, do I need to ask for something other than mothur to be updated to run 1.43.0?

I am not seeing that issue with our test files. Could you send the file pair and your logfile to mothur.bugs@gmail.com so I can take a closer look?

file pair? I’ll send those fastq and the logs.

Someone else working on the same server is having the same problem, so it’s completely possible it has to do with how our server is set up.

1 Like

Hi Kendra,

Thanks for sending your files. I ran them with our prebuilt version without issue. I noticed in your logfile of 1.43.0 that mothur did not indicate the boost library was compiled with your mothur executable. We added this output in 1.43.0, and it should look like:

Using ReadLine,Boost,HDF5,GSL

mothur v.1.43.0

Last updated: 12/06/2019

by

Patrick D. Schloss

Your logfile indicates mothur was only built with the readline library and not the boost library which is used to read the gz files.

Using ReadLine

mothur v.1.43.0

Last updated: 12/05/2019

by

Patrick D. Schloss

I suspect that there is something not quite right with the makefile options when you built. Is USEBOOST ?= yes set?

Kind regards,

Sarah

Thanks Sarah, that fixed the problem.

Mine says

Linux version

Using ReadLine,Boost
mothur v.1.43.0
Last updated: 12/06/2019
by
Patrick D. Schloss

What won’t work if HDF5 and GSL aren’t turned on?

The HDF5 library is used by the biom.info command to read biom files in HDF5 format.

The GSL library is used by the estimator.single command, https://mothur.org/wiki/Estimator.single.