Catchall on mac

I’m having trouble running the catchall command on my MacBook Pro. I put the catchall executable (CatchAllcmdL.exe) in the same folder as the mothur executable (v.1.16.0), made it executable with chmod, and installed Mono for mac intel from this website ( The program runs fine on its own outside mothur, but then I have to create the proper input file format for all my samples. When I run catchall in mothur on a shared file I get this output:

mothur > catchall(shared=LTR_ARC_Bv6.Bacteria.slp.otus.03.transpose.shared.txt)
Processing group 1_winter_epi
Cannot open assembly ‘/CatchAllcmdL.exe’: No such file or directory.
[ERROR]: the catchall program did not run properly. Please check to make sure it is located in the same folder as your mothur executable.

This happens even if I run mothur in the same folder as the mothur and catchall executables.
Do you know what is going on?

Mothur finds the catchall executable location using the argv variable for mothur. It looks like you might have mothur’s location defined in your PATH variable. Mothur is supposed to be able to parse out the executable location from the PATH environment variable, but it appears that is not working properly. Could you try running mothur with a complete path so I can tell if that is the problem you are having?

Something like, SarahsWork$ ./debug/mothur “#catchall(shared=abrecovery.fn.shared, label=0.03);”

I do have mothur’s location in my “.profile” file with this line:
export PATH=/Applications:$PATH

I used this command:
$ /Applications/mothur “#catchall(shared=LTR_ARC_Bv6.Bacteria.slp.otus.03.transpose.no_semicolon.shared.txt);”

My output was this:
mothur > catchall(shared=LTR_ARC_Bv6.Bacteria.slp.otus.03.transpose.no_semicolon.shared.txt)
Processing group LTR_ARC_Bv6_ARC_1_1B
CatchAll Version 2.0
input File: LTR_ARC_Bv6.Bacteria.slp.otus.03.transpose.no_semicolon.shared.LTR_ARC_Bv6_ARC_1_1B.0.03.csv
output path: LTR_ARC_Bv6.Bacteria.slp.otus.03.transpose.no_semicolon.shared.LTR_ARC_Bv6_ARC_1_1B.0.03.csv/

Unhandled Exception: System.IO.FileNotFoundException: Could not find file “LTR_ARC_Bv6.Bacteria.slp.otus.03.transpose.no_semicolon.shared.LTR_ARC_Bv6_ARC_1_1B.0.03.csv/”
File name: ‘LTR_ARC_Bv6.Bacteria.slp.otus.03.transpose.no_semicolon.shared.LTR_ARC_Bv6_ARC_1_1B.0.03.csv/’
at System.IO.Directory.CreateDirectoriesInternal (System.String path) [0x00000] in :0
at System.IO.Directory.CreateDirectory (System.String path) [0x00000] in :0
at MapleToCSharp.Main (System.String[] args) [0x00000] in :0
[ERROR]: the catchall program did not run properly. Please check to make sure it is located in the same folder as your mothur executable.

mothur > quit()

Okay, so mothur is finding the catchall executable. But I suspect when it creates the input files for catchall it is putting them in the same place as the shared file, but not sending catchall the complete file name. Can you check to see if the LTR_ARC_Bv6.Bacteria.slp.otus.03.transpose.no_semicolon.shared.LTR_ARC_Bv6_ARC_1_1B.0.03.csv file is being created and put in the same location as the shared file? If so, you should be able to force mothur to send the complete file name by changing your command to $ /Applications/mothur “#catchall(shared=./LTR_ARC_Bv6.Bacteria.slp.otus.03.transpose.no_semicolon.shared.txt);” Let me know if that works for you.

Hey - hate to necropost this thread, but I’m essentially having this problem with the Catchall v3.1 that I loaded up with the most recent MacOS 10.8 GUI - which I’ve been running from command line anyways.

I’ve got Mono, that seems to be running Catchall just fine. But I’m just not seeing a .csv file being created, as a Catchall input?

Here’s what I see:

mothur > catchall()

Using as input file for the shared parameter.

Processing group 8104_d20

CatchAll Version 3.1

input File: /Users/jobertbarin/mothurGUI/mothur/
output path: /Users/jobertbarin/mothurGUI/mothur//
Input data file must have more than one row
End of Analysis
[ERROR]: the catchall program did not run properly. Please check to make sure it is located in the same folder as your mothur executable.

Any ideas? What am I missing?

Can you try it with label=0.03? I think the catchall error is related to the unique distance.

Finally got around to this - system’s been super-hung up trying to run metastats (unsuccessfully, will work on that in the 'ppropriate thread).

Getting the same error, with the 0.03 label.

Although it’s now occurring to me that the problems I had been having clustering OTUs are coming back to haunt me - I expect they’ve oversplit into uniques, with no 0.03 labels. So I’m going back to wrestling with that fun stuff.