catchall not working

When trying to run catchall (windows, so not one of the allegedly cool kids :P) it gives me an error message saying the program is not in the folder or such like. I thought the catchall executable is supposed to be automatically in the mothur folder? headscratch Do I need to install something specifically?
And while I’m at it: do I need it at all? It estimates number of species, right? Doesn’t Chao already do that?
TIA, Kathrin

The catchall command in mothur is a wrapper for the catchall program. You will need to download and install the catchall executable in the same folder you have the mothur executable. Here’s a link to the download, http://www.northeastern.edu/catchall/index.html

Thanks! I’ll give it a go later.

I’m having the same error, although I put the catchall executable in the mothur folder. Do I have to rename it?

Do you have mono installed on your machine? If you are running on the Mac or Linux version you need to install mono as well. The catchall executable should be named CatchAllcmdL.exe for Mac or Linux and CatchAllcmdW.exe for Windows.

I have mono installed. But I think the problem might be in somewhere else, because mothur gives syntax error before catchall error and it says “(” unexpected for my first group (I have parentheses in my group names). When I used different data where group doesn’t have parentheses in their names then it worked fine.

Could you post the command you are running, and the exact error message mothur is giving you?

Thought I’d chime in here - also having trouble getting catchall to work. I think I might have identified the problem and hoped it would help others, but I have no idea how to fix it. Details:

Ubuntu 11.04
mothur v1.23
Catchall for linux in the folder with my mothur executable
Mono 2.0 installed
Error message in mothur:
"
Processing group A9413

0.03
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/lib/mono/1.0/mscorlib.dll’ directory.
[ERROR]: the catchall program did not run properly. Please check to make sure it is located in the same folder as your mothur executable.
"
My guess would be that mothur is confused because it’s looking for Mono 1.0 when I have 2.0 installed. But I have no idea how to tell mothur to look in the correct folder or how to down grade Mono to 1.0 (my linux skills are sketchy at best).

From looking at the mono page, http://mono-project.com/DistroPackages/Ubuntu, it looks like mono comes standard on the version of Ubuntu you have. I suspect you may have inadvertently overwritten the .dll mono is looking for when you installed version 2.0. Sorry I am not more help, :frowning:

The mscorelib.dll file is in the Mono folder, the only problem is that the path includes folder 2.0 instead of 1.0. Any hope of getting this fixed in future releases? And any thoughts on a quick and dirty work around for the time being?

I’m also using Ubuntu 11.04 and have Mono 2.5 installed by default. Everything works fine, when I use a shared file where group names have no parentheses. But when a group is named mock_1_(25) then an error shows up:

mothur > catchall(shared=…/Desktop/Mock/final.fn.0.05.abund.shared)

Processing group mock_1_(25)

0.05
sh: Syntax error: “(” unexpected
[ERROR]: the catchall program did not run properly. Please check to make sure it is located in the same folder as your mothur executable.

@Amblyomma Unfortunately, the issue you are having has to do with your installation of mono and not mothur, so we can not correct it for you. Here’s a workaround that may help:

Try running which mono, you should see something like:
~ SarahsWork$ which mono
/usr/bin/mono
This tells me the location of the mono executable my machine will use.

Then run mono --version, you should see something like:
~ SarahsWork$ mono --version
Mono JIT compiler version 2.8 (tarball Thu Oct 7 12:23:27 MDT 2010)
Copyright © 2002-2010 Novell, Inc and Contributors. http://www.mono-project.com
TLS: normal
SIGSEGV: normal
Notification: Thread + polling
Architecture: x86
Disabled: none
Misc: debugger softdebug
LLVM: supported, not enabled.
GC: Included Boehm (with typed GC)

I suspect OS is using the 2.0 install of mono with the missing dlls, so let’s put the location of the 1.0 mono install in your path to see if we can get around that.

Here’s a link to show you how to add something to your PATH: http://www.ghacks.net/2009/06/03/adding-a-directory-to-your-path/ The only change we want to make is we want to add the location of mono 1.0 at the beginning of the path. PATH=LocationOfMONO1.0:$PATH

You can confirm the change by running the which mono and mono --version commands again. I hope this helps.

@westscott: I really appreciate all of the effort that went into your response. However, I think I gave you the mistaken impression that I still had mono 1.0 on my machine, but I don’t, so I can’t change the path to point to it. I just checked the catchall website and they are recommending the latest and greatest version of mono. I tried downloading their executable and putting it in my mothur folder; I still get the same error complaining that the .dll isn’t in the (nonexistant) mono 1.0 folder. My OS is pointing to the 2.x folder. I don’t understand where the disconnect is, especially since Chris was able to get it to work on his Ubuntu machine with the same setup.

jo@Ubuntu-Sphinx:~$ which mono
/usr/bin/mono
jo@Ubuntu-Sphinx:~$ mono --version
Mono JIT compiler version 2.6.7 (Debian 2.6.7-5ubuntu3)
Copyright © 2002-2010 Novell, Inc and Contributors. www.mono-project.com
TLS: __thread
GC: Included Boehm (with typed GC and Parallel Mark)
SIGSEGV: altstack
Notifications: epoll
Architecture: amd64
Disabled: none