mothur

Valid Mothur commands

Hi,
I’m currently using mothur v.1.42.0 on Linux-ubunto
Sometimes I face errors because of invalid commands and then I check for the right one (for example chimera.vseach>>> chimera.uchime) and the error would be solved
My question is, is the following list is the only valid command by the latest mothur version (as stated by mothur when encountering an error):
Valid commands are: align.check,align.seqs,amova,anosim,bin.seqs,catchall,chimera.bellerophon,chimera.ccode,chimera.check,chimera.perseus,chimera.pintail,chimera.slayer,chimera.uchime,chop.seqs,classify.otu,classify.rf,classify.seqs,classify.svm,classify.tree,clear.memory,clearcut,cluster,cluster.classic,cluster.fragments,cluster.split,collect.shared,collect.single,consensus.seqs,cooccurrence,corr.axes,count.groups,count.seqs,create.database,degap.seqs,deunique.seqs,deunique.tree,dist.seqs,dist.shared,fastq.info,filter.seqs,filter.shared,get.commandinfo,get.communitytype,get.coremicrobiome,get.current,get.dists,get.group,get.groups,get.label,get.lineage,get.mimarkspackage,get.otulabels,get.otulist,get.oturep,get.otus,get.rabund,get.relabund,get.sabund,get.seqs,get.sharedseqs,hcluster,heatmap.bin,heatmap.sim,help,homova,indicator,kruskal.wallis,lefse,libshuff,list.otulabels,list.seqs,load.logfile,make.biom,make.contigs,make.fastq,make.file,make.group,make.lefse,make.lookup,make.shared,make.sra,make.table,mantel,merge.files,merge.groups,merge.sfffiles,merge.taxsummary,metastats,mgcluster,mimarks.attributes,nmds,normalize.shared,otu.association,otu.hierarchy,pairwise.seqs,parse.list,parsimony,pca,pcoa,pcr.seqs,phylo.diversity,phylotype,pipeline.pds,pre.cluster,primer.design,quit,rarefaction.shared,rarefaction.single,remove.dists,remove.groups,remove.lineage,remove.otulabels,remove.otus,remove.rare,remove.seqs,rename.seqs,reverse.seqs,screen.seqs,sens.spec,seq.error,set.current,set.dir,set.logfile,set.seed,sff.multiple,sffinfo,shhh.flows,shhh.seqs,sort.seqs,sparcc,split.abund,split.groups,sub.sample,summary.qual,summary.seqs,summary.shared,summary.single,summary.tax,system,tree.shared,trim.flows,trim.seqs,unifrac.unweighted,unifrac.weighted,unique.seqs,venn,

because the Miseq SOP, mothur command list on mothur wiki page and mothur manual have so many many commands other than those listed above.

Thanks a lot!

Perhaps a better list can be found at https://mothur.org/wiki/Category:Commands

Thank you
yes I viewed all the commands in the list. and I was asking if one of this commands doesn’t work in my version of mothur (the latest one) due to “invalid command” message from mothur, not another error. DO I need to install some packages for more commands maybe or something like that?

No there’s nothing else that you need to install. Sometimes we deprecate a command or add a command and forget to remove/add it from all the lists.