Uchime stops working

I am trying to process MiSeq data with MOTHUR on a 12 cores windows computer containing 64 GB memory. MOTHUR crashes during the uchime step.
MOTHUR starts the chimera detection step (uchime.exe) normally but stops after a while with the message “uchime.exe has stopped working”, “a problem caused the program to stop working correctly …”.
Is there a way to overcome this problem?

The problem is likely do to the amount of RAM you have and the number of processors you’re trying to use at once. You might turn it down to 4 processors or even 1 and see if you still get the problem. Also, if you only have a 32bit version of windows you won’t actually have access to the full 64GB of RAM.


I’ve tried to use only one processor without succes and I do have a 64bit Windows version. It is a large dataset containing a complete MiSeq (v2 2x 250bp) run sequencing the v4 region of 50 samples.
Is this problem related to the use of Windows?

Mothur’s chimera.uchime command is a wrapper for the uchime program written by Robert Edgar, http://drive5.com/usearch/manual/uchime_algo.html. The error you are getting is from the uchime program and is a memory issue. The uchime program is 32bit which limits its memory usage to 4G.

Thank you both for the replies.
Does this mean that I wo’nt be able to remove chimeras from my dataset with Uchime? Or, is there any alternative approach available that can be incorporated in the Mothur workflow to remove chimeras?