Forum members,

I would like to run the tree.shared command, but am getting stuck. Wiki manual says the command format should be:

mothur > tree.shared(shared=abrecovery.fn.shared)

or command + options would look like:
mothur> tree.shared(shared=*.shared, calc=jest-thetayc-braycurtis)

But Mothur.exe says that “shared” is not a valid parameter.

I have the *.dist, *.fn.list, *.groups, and *.fn.shared files. Any suggestions on how to format the command line to output a newick tree?


What version of mothur are you running?

I am running mothur v.1.15.0 last updated December of 2010.

The complete message is:
shared is not a valid parameter.
The valid parameters are: label, calc, groups, phylip, column, name, precision, cutoff, outputdir, and inputdir.
You must run the read.otu command or provide a distance file before running the tree.shared command.

Other information that may be helpful:

Based on a forum post “Unifrac Distance Matrix -> Newick using R” I tried running
mothur >tree.shared(phylip=.dist)
but that also does not work. It starts to run, then closes down without completing. If I run read.dist(phyllip=
.dist, cutoff=0.10) the matrix will load just fine.

The wiki documentation reflects commands in our current version. In version 1.18, we removed the read commands and allowed the file names to be provided directly to the commands that use them, which is why the shared parameter got added to the tree.shared command. I would strongly recommend upgrading to version 1.21.1. We have added several new commands and features you may want to use, as well as a critical bug fix to the chimera.slayer command in version 1.19. Here’s a link to the download page,

Hi Wescott,

Thank you for the reply.

If I download the new version, will I be able to just “plug in” the files that I already have (*.dist, *.fn.list, *.groups, *.fn.shared etc)? Or will I need to start the whole analysis over again?

Thanks for your help.


You do not need to start over your analysis from the beginning, but I would recommend going back to the chimera checking step. The bug we fixed with the chimera.slayer decreased the false positive rate. You could try the chimera.uchime command for chimera detection.

Thank you.