get.otus with shared file


I ran into a bug with the get.otus command, but I have to admit that I still use v.1.36.1.
Please let me know if you have fixed the bug in the current version (v1.38.0), thus if it is worth asking our IT department to get a new version installed before I go further with my analyses.

According, to the mothur wiki, it is possible to use a shared file in the get.otus command, but when I run the following, I get an error message:

mothur > get.otus(groups=CtrS1-CtrS2-NTC,, label=0.03)
shared is not a valid parameter.
The valid parameters are: group, list, accnos, groups, label, seed, inputdir, and outputdir.
You have no current group file and the group parameter is required.
You have no current list file and the list parameter is required.
[ERROR]: did not complete get.otus.

Kind regards, Anke.

The shared parameter was added to the get.otus command in version 1.37.0. I would recommend upgrading to our latest version at your earliest convienence. Here is a possible workaround in version 1.36, if I am remembering the parameter options correctly, :slight_smile:

mothur > list.otulabels(groups=CtrS1-CtrS2-NTC,, label=0.03) - list otus with sequences from groups you want
mothur > get.otulabels(, label=0.03, accnos=outputFileFromListOTUlabels) - select those OTUs from shared file