Tree.shared and parsimony problem

Hi All,

I’m having an issue with running a few commands. I’m following the Schloss protocol. I ran tree.shared(calc=thetayc-jclass) to build a tree. Then I tried running parsimony(tree=current, group=current, groups=all) command but Mothur is listing a bunch of files that are “in my groupfile but not in my tree and will be disregarded”. I used the same groupfile that I used to build my shared file. I even went back and took the information from my .names file to build a new groupfile thinking maybe the error had something to do with the unique samples. Unfortunately, I get the same error. I don’t know why I would be missing sequences, so I’m thinking this could be a glitch. I’m using version 25. Any advice would be appreciated. Thanks.


So if you’re running parsimony or the unifracs on a tree generated by tree.shared, then you need to give it a group file that has the name of the groups in the first column and treatments in the second column. The current group is probably sequences in the first column and groups in the second column.


Ah … I didn’t see that and I didn’t catch the difference in group format in the protocol. What if my groups are my conditions? In other words, what if I want to see whether there are differences across my groups? Is this still the best method for comparing that using parsimony and unifrac? Should I still generate a shared tree using the theytayc & jclass values? I only ask because I made changes to my groups file using each group as the condition, but when I ran parsimony, I got a value of 1 for all the comparisons. Does that mean my groups are very similar, or am I interpreting it wrong? Thanks for the advise.



Hi, I have a similar problem - I am trying to get parsimony and unifrac.(un)weighted to analyze a tree I made with clearcut. mothur(v.1.26) keeps crashing and saying “…” is not in your groupfile. But I made my groupfile from my fasta file I used in the phylip which was used by clearcut and double checked and the name is there. Maybe it is too long or contains forbidden characters? I have run into that problem on the Unifrac website. I have gotten these commands to work fine before (with a different set of seqs) using the same version of mothur, so I’m stumped.

I notice that sometimes when I use clearcut, the tree will open in MEGA, and sometimes it will not. In the case of the error, it will not; but times parsimony and unifrac have worked, I can open the tree in MEGA. So I’m guessing the problem is in the tree itself maybe?

Thanks for any suggestions! And thanks for making such a great program!

dr.jen, can you email us your treefile, group file and name file ( and include the link to this page in the email?