Template not aligned error for silva reference alignment (v123)


I refer to an earlier post on the successful alignment of 16S sequence using the latest silva reference alignment (v123) (align.seqs using silva.nr_v123). I have tried doing so using the command “align.seqs(fasta=sample.trim.contigs.good.unique.fasta, reference= silva.nr_v123.align)” but i got the error “template is not aligned, aborting.”

I performed summary.seqs(fasta= silva.nr_v123.align) and got the following output:

Start End NBases Ambigs Polymer NumSeqs
Minimum: 1045 28491 905 0 5 1
2.5%-tile: 1046 43116 1402 0 5 25
25%-tile: 1046 43116 1453 0 6 248
Median: 1046 43116 1699 0 6 495
75%-tile: 1046 43116 1731 0 6 742
97.5%-tile:1046 43116 1760 3 7 964
Maximum: 1103 43116 2648 5 15 988
Mean: 1046.08 43101.2 1596.67 0.308704 5.97166

of Seqs: 988

Am I missing out something?

Did you get any error messages? The issue looks like the issue could be coming from the space before the reference filename. I think mothur may be grabbing an old reference filename using the current option and attempting to align using that file. For the summary.seqs command it looks like mothur couldn’t find the reference file and used your fasta file??

align.seqs(fasta=sample.trim.contigs.good.unique.fasta, reference= silva.nr_v123.align)
summary.seqs(fasta= silva.nr_v123.align)

Hi Sarah,

Thanks for the reply. I tried both align.seqs and summary.seqs commands again, removing the space before the reference filename, but still got the same outputs.

I noticed that the file size of silva.nr_v123.align file was only 47.2 MB and the summary.seqs command indicated only 988 sequences. It does look like I’m missing out on alot of sequence information when I did the file decompression. Could this be the issue? I’m using IZArc for file decompression by the way. Any good file decompression software to recommend?

The file should be about 7G and contain over 150,000 sequences. Can you try decompressing it again?