St9bad_alloc has occurred in the InteractEngine class functi


I would like to ask about ERROR!
I tried to run the get.oturep however it does not work completely like below.

mothur > get.oturep(,,,
Reading matrix: |||||||||||||||||||||||||||||||||||||||||||||||||||

[ERROR]: St9bad_alloc has occurred in the InteractEngine class function getInput. Please contact Pat Schloss at, and be sure to include the mothur.logFile with your inquiry.

this is my logfile and i want to know what’s wrong.
I found "[ERROR]: St9bad_alloc " caused by small memory.
I tried with 8GB RAM but it didn’t work and show same error.

Please answer what’s wrong and how i handle my data.

Thank you very much for your kind help!

The error you are getting indicates you are running out of RAM. How big is your distance file? The get.oturep command has a parameter called large. If you set large=t, mothur will assume your distance file is too big to fit in RAM. With large=t, the command will take longer to complete, but may solve your problem.