get.oturep killed


I’m trying to get a representative sequence for each OTU. I ran get.oturep but our computational cluster kills the process, I guess it’s a matter of not enough memory, which is strange since we have 24 GB of RAM per node in an 8 intel Xeon processor in our biocluster. I guess I can tray running it in the large memory queue (1024 GB, 24 intel), but, Is there and alternative way to run this or an alternative script without using all that computational resource?

The way I’m running the command is this:

mothur > get.oturep(,, list=HHowler.list)

My dist file is 25 GB

Thanks in advance for tips


You distance matrix is 25 GB and you have 24 GB of RAM. And there’s other stuff (e.g. the list file and name file) that you have to store…

You might try the cutoff parameter or the abundance method.

According to the previous question, my distance matrix is 144Gb but we have 200Gb RAM on our cluster, so it starts to work but then creates a gigantic temporary file up to the whole free space we have on our cluster (850 Gb). And then stops working and gives me the error of “write failed: no space left on device”! I tried method=aboundance and it went well, but I prefer to use the distance method. I wanted to use cutoff option as well but have no clue how to use it as there is no example on the website about it.
I would be very thankful if you could kindly help me out to manage running this command.
Thanks a lot