split.groups error


I’ve run the chimera.uchime and then the remove.seqs commends. I’d now like to split my dataset back into groups.

I have tried the split.groups command but I’m getting the error

Error in reading your fastafile, at position -1. Blank name.

I’m not quite sure what I have done wrong.

Any suggestions?


Here is a more detailed account of the error…

mothur > split.groups(fasta=stability.trim.contigs.good.unique.pick.fasta, count=stability.trim.contigs.good.count_table)

[ERROR]: Could not open stability.trim.contigs.good.unique.pick.aR1-5.fasta
. (same thing for all groups reported)…

[ERROR]: Could not open stability.trim.contigs.good.aWT12-6.count_table
[ERROR]: Could not open stability.trim.contigs.good.unique.pick.aWT12-7.fasta
[ERROR]: Could not open stability.trim.contigs.good.aWT12-7.count_table
[ERROR]: Could not open stability.trim.contigs.good.unique.pick.fasta
Error in reading your fastafile, at position -1. Blank name.

When I watch the folder it is working in, it briefly makes all these files and then deletes them.

I had done the same thing on a test set that worked fine. I am not sure why it is not working now.

From the log file…

Mac version

Using ReadLine

Running 64Bit Version

mothur v.1.32.1
Last updated: 10/16/2013

Can you try running the command with our current version, 1.38.1 https://github.com/mothur/mothur/releases?