mothur

[Error] stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.pick.fasta is blank. Please correct

Hello,

I’m a new mothur user using the version 1.43.0 and I’m not sure it’s a bug but I always get this error message after phylogenetic command:

Blockquote mothur > dist.seqs(fasta=stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.pick.fasta, output=lt, processors=8)
[ERROR]: stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.pick.fasta is blank. Please correct.
Using 8 processors.
Sequence Time Num_Dists_Below_Cutoff
Segmentation fault

I followed the steps on MiSeq_SOP wifi page and the same error message appears when I try it with example data from Schloss lab. And if I just skip phylogenetic steps and use analysis commands it says it’s unable to open stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.pick.opti_mcc.shared.

I would like to upload a logfile so it might be easy to troubleshoot but I don’t know how to upload since it doesn’t allow me to upload other than jpg file.

Any idea why this happens? Thanks!

Hi there,

It should not be a bug. I am also a newbie to Mothur. I just followed the SOP for all steps, and I did not encounter this issue.
I am guessing that the issue exists in your stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.pick.fasta file. You can open this file and see if it is truly blank. If it is trult blank, then, I think that your command of get.groups(count=stability.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.pick.pick.count_table, fasta=stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.pick.fasta, groups=Mock) has some issues.

Or, maybe you skipped the Mock community steps? If so, you might need to change the file names accordingly to avoid the issue that you are facing.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Could you send your logfile to mothur.bugs@gmail.com?