mothur

Split.abund bug

Hello,

I am not sure if I can say this is a bug.
I happened to run split.abund before chimera.vsearch (Plz, don’t ask me why)
Some of my samples were not sequeced well, having only a few reads. Thus should be removed after split.abund. However, the abund.count_table still have the sample names that have no sequences. And this seems to cause a problem with chimera.vsearch. Chimera.vsearch stops after splitting files

It would be nice if split.abund removes samples from abund.count_table if they have no sequences.

For now, I just removed them manually and started chimera.vsearch, which worked fine.

Thank you,
Tatsu

I am not seeing that in our current version, Release Version 1.44.3 · mothur/mothur · GitHub. Can you try upgrading to see if the problem persists?

Hi, thanks for checking.
I am using the latest version on my ubuntu server.
After running split.abund, my abund.count_table contains sample names that have 0 sequences, just because all of their seaquences are now in rare_count.table.
With this abund.count_table, somehow chimera.vsearch terminates after splitting files into each sample.
chimera.vsearch worked fine after I removed those samples from abund.count_table.

As a matter of fact, if you run count.groups to the abund.count_table, you get message something like
“Removing group: XXXX because all sequences have been removed.”

I think it would be nice either split.abund removes these from abund.count_table or chimera.vsearch works with the count_table that have samples with no sequences.

Thanks for your help,
Tatsu