Sff.multiple - problem with oligos file in the last file


I tried Sff.multiple command using a list of 25 files, in Mothur v.1.28.0, Linux 64 bit version.

I had a problem with only the last file of the 25, with trim flows:

Running command: trim.flows(flow=H57KI5M03.MID153.flow, oligos=MID_oligos.txtÿ, maxhomop=8, maxflows=450, minflows=300, pdiffs=2, bdiffs=1, ldiffs=0, sdiffs=0, tdiffs=3, signal=0.5, noise=0.7, order=TACG, processors=1)
Unable to open MID_oligos.txtÿ

I figured the ÿ character is an end-of-file indicator, but did I do something wrong, or is it a bug?

I think your oligos file needs to be renamed to MID.oligos . Remove the txt extension completely. Then .oligos becomes the extension which is the required format.


Mothur was reading the end of file character as part of the oligos file name if there was not a blank line at the end of the file. This issue was fixed in version 1.30.0. You can upgrade to 1.30.0 or add a blank line to correct the issue.

Yes, in the meantime I added an extra line and it worked. I did not see it being fixed in the new version, but, then I upgrade! Thank you!

Nope, it always worked like this as well. But thank you!

Thanks for the heads up. I forgot to add it to the release notes for 1.30.0.