mothur

Remove.rare taking a long time to run

Hi,

I am trying to remove rare OTUs using the remove.rare command. Since I generated my list with a count table, I also included that in the command.

It has been running for about two days now. My list was based on unique sequences (not clustered based on 0.03), as I am working with data where SNPs are important for allele designation.

Is there any way to increase the speed of this process? I notice I cannot designate how many processors to use, and looking at the task manager it looks like it is only using one.

Any help is greatly appreciated.

Can you post the exact syntax you are using? ALso, what happens if you only provide the list file and not the count table?

Pat

Hi Pat,

This has been resolved. I took your advice to contact mothur.bugs@gmail.com (via a twitter response).

The person helped immensely.

mothur > remove.rare(shared=mhc.shared, nseqs=2, label=0.0)
Your file does not include the label 0.0. I will use 0.
0

Output File Names: 
/Users/joel/Desktop/rare/mhc.0.pick.shared

mothur > list.otus(shared=current)
Using /Users/joel/Desktop/rare/mhc.0.pick.shared as input file for the shared parameter.
0

Output File Names: 
/Users/joel/Desktop/rare/mhc.0.pick.0.otulabels

mothur > get.otus(list=mhc.list, accnos=mhc.0.pick.0.otulabels)
You did not provide a label, I will use the first label in your inputfile.
Selected 95143 OTUs from your list file.

Output File Names: 
/Users/joel/Desktop/rare/mhc.0.pick.list

mothur > list.seqs(list=current)
Using /Users/joel/Desktop/rare/mhc.0.pick.list as input file for the list parameter.

Output File Names: 
/Users/joel/Desktop/rare/mhc.0.pick.accnos

mothur > get.seqs(count=mhc.count_table)
Using /Users/joel/Desktop/rare/mhc.0.pick.accnos as input file for the accnos parameter.
Selected 542001 sequences from your count file.

Output File Names: 
/Users/joel/Desktop/rare/mhc.pick.count_table

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.