mothur

Remove.groups (v.1.44.3) doesn't remove last listed group

Hi,

Not sure whether this bug is specific to my local machine or a true bug of the 1.44.3 release. When running “remove.groups” on my local machine (macOS 10.14.6; mothur v 1.44.3), the last group on the list doesn’t get removed. E.g.:

remove.groups(shared=final.shared, groups=a-b-c-d) would only remove groups “a-b-c”, leaving “d” in the outputted “final.pick.shared”.

I’ve tried running the same command on the same files on our server (Ubuntu 14.04.6 LTS; mothur v 1.42.3) and the command runs fine, removing all desired groups.

All the best,
Guillaume

Hi Guillaume,
I am not able to reproduce the issue you are having on my test machine. Could you send your shared file to mothur.bugs@gmail.com so I can take a closer look?
Kindly,
Sarah

Hi Sarah,

Thanks for getting back to me and apologies about not updating my post. After a few trials on server vs laptop, I think the problem arises when running in batch mode only for some reason, and not every time (e.g. ran into the same issue on the v. 1.42 on the server in batch mode). I think this is a very minor issue but if you think it still needs addressing, I’m happy to send files over but only if you think it is worthwhile for you guys.

Thanks again,

Guillaume

Thanks for the added information. Could you send your files to mothur.bugs@gmail.com so I can take a closer look?

Hi Sarah,

Tried to re-run the remove.groups command on both v.144.3 and v.1.42.3 and two different machines using the same files as before in both manual and batch mode, and now everything seems fine. Really don’t know how the weird issue arose in the first place, whether there might have been some typo in my batch old batch file or something.

Apologies for the time wasting and really impressed by how quickly you tried to address the issue, thank you. I’m happy to delete my posts.

Thanks again,

Guillaume

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.