mothur

Rarefaction.single processors parameters remove


#1

Hi Schloss,

Thanks for your nice working of mothur.

It is said that the speed of rarefaction.single has been increased.

However, when I calculate the rarefaction of the diversity index, it seems slower with the removing of processors parameters.

rarefaction.single(shared=otus.shared,calc=sobs-chao-shannon,groupmode=f,freq=100,processors=5)

Do you suggest that we go back to the old version for quicker calculation?


#2

No, you should never use an older version of mothur. How long do the following commands take to run?

rarefaction.single(shared=otus.shared,calc=sobs-chao-shannon,groupmode=f,freq=100,processors=5)

and

rarefaction.single(shared=otus.shared,calc=sobs-chao-shannon,groupmode=f,freq=100,processors=1)

#3

when using 5 processors, it took 8 minutes.
when using 1 processor, it took 40 minutes.
And the new version of mothur 1.40.5 is exactly the same as 1.30.2


#4

Sorry, I’m confused… What are you expecting the result to be? The default is processors=1 and one would expect 1 processor to take 5 times longer than using 8, which is what you are seeing.


#5

I mean in the new version, there is no “processor” parameters. Thus, the speed becomes slow.
So should I keep using older version (which has the processor) parameter?
At the beginning, I thought the new version would be faster. But it is not.
Sorry for unclear description.


#6

In the rewrite of mothur’s threaded code for version 1.40.0, we removed the processors option from the rarefaction.single command. We have plans to address this in a later release. You can follow the progress here, https://github.com/mothur/mothur/issues/546.