Problems writing .dist file

Hello everyone,

I am trying to run some of my files through mothur on Mac OSX 10.6.7 with the following steps:
unique.seqs -> fine
chimera.slayer -> fine
remove.seqs -> fine
align.seqs -> fine
filter.seqs -> fine
dist.seqs -> using the command

mothur > dist.seqs(fasta=file.unique.pick.filter.fasta, cutoff=0.1,processors=2)

runs fine and says that file.unique.pick.filter.dist has been written.

The *.dist-file however is empty, which happens with cutoff=0.1, 0.3 or 1. Has anyone seen this and has an idea how to solve it?
Thanks in advance,

First off - the order of your commands doesn’t make sense… You probably want to order what you’re doing like so…


Second, I don’t see a screen.seqs step, which makes me wonder if when you run filter.seqs(trump=.) you are removing all of your sequence data and so the distances get messed up. Can you check on this?

Truly looking for chimeras in unaligned data doesn´t make sense and mothur is probably an intelligent enough piece of software to prevent this. Checking my logfiles revealed that I actually had the right order of commands and just put it down wrongly in my last post.
Now, I also included rather rigorous screen.seqs steps now restricting to 99% start and stop positions.
The resulting alignment looks ok to me. After filtering (with trump=., vertical=T) it still does not produce any content in the .dist file (output on screen is there, just doesn´t end up in the file).
I also tried dist.seqs using the sogin.unique.filter.fasta data set with no result either, which makes me think it´s something to do with my machine. I also reran on my macbook at home with no improvement. Can it be that installer, the default .dist association, interferes with file writing somehow? Since I can create .dist files from text edit without problems, this seems unlikely, but I cannot think of anything else…

Sounds like something strange is going on. What version of mothur are you running? Did you build the executable yourself or did you download the executable version from the wiki?

In the meantime I figured out what the problem might be:
I was using the inputdir option because in the end I wanted to run batch files on multiple data sets. All steps until dist.seqs were running fine this way and dist.seqs also seemed to open the file in the correct destination but writing into that file somehow ended up in the void. The problem occured with version 1.17.3 as well as with the previous version, which I compiled myself (I think…). Starting mothur from the right directory solved the problem.