mothur

Mismatch in align and tax file?

Hi!

I recently tried running mothur on CyVerse (Ubuntu command line). I downloaded both mothur (and all its buddy tools) as well as the silva database directly to the site using wget. I.e.:

wget https://github.com/mothur/mothur/releases/download/v1.46.1/Mothur.Ubuntu_20.zip
unzip Mothur.Ubuntu_20.zip
rm Mothur.Ubuntu_20.zip
mv mothur/ Mothur/
mv Mothur/* ./

#Get databases
wget https://mothur.s3.us-east-2.amazonaws.com/wiki/silva.nr_v138_1.tgz

#Uncompress database file
tar xzvf silva.nr_v138_1.tgz

#Start mother
./mothur

Everything runs hunky-dory until I get to the classify step, where I try and classify the reads using teh unaltered, untouched silva files:

#Next we need to identify the seqs
classify.seqs(fasta=ABC.trim.contigs.good.unique.pick.fasta, count=ABC.trim.contigs.good.pick.count_table,reference=silva.nr_v138_1.align, taxonomy=silva.nr_v138_1.tax, cutoff=80)

This resulted in several iterations of " ‘XXX’ is in your template file and is not in your taxonomy file. Please correct."

I rootled around online and found some people had had a similar issue and tried the following work around that had been suggested 18S Analysis: Trimmed align file used in classify.seqs is missing taxons · Issue #505 · mothur/mothur · GitHub :

#Fix the broken databases

list.seqs(fasta=silva.nr_v138_1.align)
get.seqs(taxonomy=silva.nr_v138_1.tax, accnos=silva.nr_v138_1.accnos)

I also looked for any naughty spaces that may be in the tax file, as suggested by Dr. Schloss in this post classify.seqs errors in reading taxonomy file.

However, upon running the classify.seqs step after that (with my newly made silva.nr_v138_1.pick.tax file), I had the same error that may have actually had more “missing” taxa.

The most puzzling part is, is that I ran this exact set of sequences through mothur (with the same 138 silva release) on both my Mac and on one of our Linux servers without issue. I similarly tried using the databases (tax and align) that I had downloaded to each of those in the Cyverse environment, and alas, the same error. I’m very flummoxed.

Any help on getting this working would be really appreciated! :slight_smile:

Sam

I use the terminal app to run mothur, not CyVerse. I am not able to reproduce this issue on our Ubuntu test machines with terminal.

Oki dokes! Ya, I couldn’t reproduce it in terminal either. I’ll bug the CyVerse admin and see if they know what the problem is :slight_smile: Thanks all the same!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.