classify.seqs resulting in mismatch with tax and templ files


I tried to classify my sequences with Mothur v. 1.12.3 using silva files you provide on your wiki (nogap.bacteria.fasta and to be specific, the files were downloaded today). The result was “Mismatch with taxonomy and template files. Cannot continue”… :?
The command issued was: classify.seqs(fasta=myseqs.fasta, template=nogap.bacteria.fasta, The taxonomy was read in, also the search db and templ. probs were calculated normally. The error occured at the stage of actual classification. Is there a chance that I downloaded corrupted silva files? I tried all taxonomy outlines that were provided - none of them appears to work. However, the files look normally - the nogap file is an unaligned fasta and the tax files seem to be in the correct format. One thing is, the accessions in taxonomy outlines are sorted alphabetically, while in the nogap and silva.bacterial.fasta they are not. Does it matter at all?

Please download v.1.14 and the current set of reference files and try again.

I did as you said. V. 1.14 is unable to calculate templ. probs - it eats up all the memory and then “std::bad_alloc has occured in the MothurOut class function getline.” I tried both the executable that you provide and a version compiled at home - the results were the same.
The system was Fedora 14 x86_64.

Weird - that error typically means you ran out of RAM - how much RAM does your computer have? BTW, the ordering doesn’t matter.

First I ran the analysis on 2 GB RAM laptop, then on 12 GB server - results the same, Mothur ate up all the RAM, then all swap space and died. One thing, the larger machine runs Ubuntu 10.10 not Fedora.

Best regards,

In version 1.13.0 we added version information to the classifier’s shortcut files. It seems like mothur may be having problems reading the version information. Could you try removing the .tree.train and .tree.sum files, and then run the command again?

I tried to run the command again with templ. and tax files in an otherwise empty directory. The problem persists… I attach a logfile, may be it will be helpful.

Best regards,

I can’t post neither .logfile nor .logfile.txt files. Which extensions are allowed?

Can you email them to