Dear all,

I have a problem is with the command classify.seqs

It performed well with the file silva.slv.taxonomy on my data and on your file-examples, but not with the other files rdp/gg and embl.taxonomy downloaded from your Web site.

With the command :
mothur > classify.seqs(fasta=sogin.unique.filter.fn.0.10.rep.fasta, template=silva.bacteria.fasta, taxonomy=silva.rdp.taxonomy, processors=7)

I obtain:
Reading in the silva.rdp.taxonomy taxonomy… DONE.
Generating search database… DONE.
It took 6 seconds generate search database.
Calculating template probabilities… Erreur de segmentation

Could you help me?

Many thanks


Would you mind sending you logfile and the fasta file to so I can take a look for you?

I have encountered the same problem, but I found the input fasta file must be “aligned” and it works. Try it!

Good luck.

Actually the alignment doesn’t matter. For right now, just make sure that you are using the fasta file that comes with the taxonomy files and not the one from the reference alignment. You might have to get rid of the *mer file as well. I need to fix this but haven’t had a chance - the problem is in the reference files not the software.


whenever I try to use classify.seqs I get the following error:

mothur > classify.seqs(fasta=nat.final2.fasta, template=silva.bacteria.fasta, taxonomy=silva.slv.taxonomy, method=bayesian, cutoff=80, group=nat.final2.groups, name=nat.final2.names, probs=F)

Reading in the silva.slv.taxonomy taxonomy... DONE. Generating search database... DONE. It took 7 seconds generate search database. Calculating template taxonomy tree... DONE. Calculating template probabilities... DONE. It took 126 seconds get probabilities. Classifying sequences from nat.final2.fasta ... Segmentation fault bagside@bagvapp:/media/LACIE/mothur3$

I am currently using v1.10


I think this is due to ;; in the taxonomy file. :oops: We will be fixing the files on the wiki, but for now if you do a find for ;; and replace it with ;, it should work. The next version will include more error checking on the taxonomy file as well as checks for consistency between the taxonomy and template files.

When I look at the rdp.taxonomy file, it does not contain any ;; , is there anything else that should be changed?

I am also getting segmentation faults running classify.seqs with v. 1.10 (running on Mac OsX 10.6.3 - I’ve tried both the executable and the source code version of mothur). I tried downloading the taxonomy files again, and deleted the *mer files, but still didn’t make it to the end.

Could you guys please either email a copy of your sequence file to or post a copy to the wiki?


Hi All,

I’ve come across this segmentation error also. I had been attempting to classify pyrosequencing data with mothur version 1.10. After getting this error, I decided to try the AbRecovery example fasta files, but using these also resulted in a segmentation error. For both my pyro data and the AbRecovery data, the classification partially works and results in the following files being created: *.taxonomy.temp, *.silva.slv.taxonomy, silva.slv.silva.bacteria.8mer.prob, silva.slv.silva.bacteria.8mer.numNotZero, silva.slv.tree.train, silva.bacteria.8mer, and silva.slv.tree.sum. No *.tax.summary file is created. I incorproated the fix in the taxonomy files suggested by Sarah Westcott, but the error still occured. After the latest attempt with the modified taxonomy file, the following error messages came up:

mothur > classify.seqs(fasta=abrecovery.fasta, template=silva.bacteria.fasta, taxonomy=silva.slv.taxonomy, processors=2)

Reading template taxonomy… DONE.
Reading template probabilities… mothur(3093) malloc: *** error for object 0x100625460: incorrect checksum for freed object - object was probably modified after being freed.
*** set a breakpoint in malloc_error_break to debug
Segmentation fault

I hope this helps to solve the problem.


The silva.slv.silva.bacteria.8mer.prob, silva.slv.silva.bacteria.8mer.numNotZero, silva.slv.tree.train, silva.bacteria.8mer, and silva.slv.tree.sum are all files that mothur generates to save time if you are using the same template and reference taxonomy files. Even though you made the change to eliminate the ;; problem, if these files are still on your machine mothur will read them instead of regenerating them from your taxonomy and template file. Try deleting these files and rerunning.

Thanks for the advice with the classify command. However, after I replace the ;; in the taxonomy file with ;, mothur freezes when trying to read the taxonomy file. I removed all the temporary files that you mentioned before running mothur with the modified taxonomy file. However, I am able to get the classify function to work using mothur v1.9 and the taxonomy files associated with that release (silva.slv.taxonomy is from January 3, 2010, and silva.bacteria.fasta is from March 3, 2009). For both tests, I am still using the AbRecovery data set. Any thoughts?


Could you send your files to

Have you downloaded the latest version of the taxonomy files and tried that?