make.shared not executed

Dear all,

I followed the 454 SOP. However, when I run make.shared(, group=merged.good.pick.pick.groups, label=0.03) the command doesnt get executed. The .shared file in my directiory is empty and theres no .rabund file.

I already ran this command before without troubles. The only thing I changed this time, is the reference database. I used before, and this time I`d like to use silva.nr_v119.fasta.

Because silva.nr_v119.fasta is bigger than I wonder, if the command does not work because of lack of memory? Or does this even have an association? Or anyone has any other ideas?

Any kind of help appreciated! Thank you.

Can you post the exact commands you are running and the error message you are getting?

this is my script:

mothur >, groups=A)
mothur > unique.seqs(fasta=merged.fasta)
mothur > align.seqs(fasta=merged.unique.fasta, reference=silva.nr_v119.align, processors=2)
mothur > screen.seqs(fasta=merged.unique.align, name=merged.names, group=merged.groups, end=27654, optimize=start, criteria=95, processors=2)
mothur > filter.seqs(fasta=merged.unique.good.align, vertical=T, trump=., processors=2)
mothur > unique.seqs(fasta=merged.unique.good.filter.fasta, name=merged.good.names)
mothur > pre.cluster(fasta=merged.unique.good.filter.unique.fasta, name=merged.unique.good.filter.names, group=merged.good.groups, diffs=2)
mothur > chimera.uchime(fasta=merged.unique.good.filter.unique.precluster.fasta, name=merged.unique.good.filter.unique.precluster.names, group=merged.good.groups, processors=2)
mothur > remove.seqs(accnos=merged.unique.good.filter.unique.precluster.uchime.accnos, fasta=merged.unique.good.filter.unique.precluster.fasta, name=merged.unique.good.filter.unique.precluster.names,group=merged.good.groups, dups=T)
mothur > classify.seqs(fasta=merged.unique.good.filter.unique.precluster.pick.fasta, name=merged.unique.good.filter.unique.precluster.pick.names, group=merged.good.pick.groups, template=silva.nr_v119.align,, processors=2)
mothur > remove.lineage(fasta=merged.unique.good.filter.unique.precluster.pick.fasta, name=merged.unique.good.filter.unique.precluster.pick.names, group=merged.good.pick.groups,, taxon=Mitochondria-Chloroplast-Archaea-Eukaryota-unknown)
mothur > dist.seqs(fasta=merged.unique.good.filter.unique.precluster.pick.pick.fasta, cutoff=0.15, processors=2)
mothur > cluster(column=merged.unique.good.filter.unique.precluster.pick.pick.dist, name=merged.unique.good.filter.unique.precluster.pick.pick.names)
mothur > make.shared(, group=merged.good.pick.pick.groups, label=0.03)

I don`t get an error message printed to the console. However, I just had a look at the Logfile, where it says that sequences are in my groupfile, but not in the listfile. Am I using the wrong .groups file? Seems a little strange to me, since -as said- the exact same code worked before.

Do you only have one group - A ? If so, you don’t need a shared file since it would be the same as the list file.

Ok, I got it that my .groups file is wrong.
What I actually would need is a .groups file that contains all my sample names.
Is there a way to do it without the trim.seqs step, where I originally in a previous run included the .oligos files indicating the sample names?

Thank you very much!

Is there a way to do it without the trim.seqs step, where I originally in a previous run included the .oligos files indicating the sample names?

I’m not sure what this means… You can make a groups file like you did with, but by chaining the fasta and group names together…, groups=A-B-C)

Thanks a lot for your help!