make in Linux (installing)

I want to install mothur (Linux) on my standalone 64 gb computer (no network access) which has ubuntu 11.10 and Oracle VM virtual box4 installed.

On mothur website, I downloaded Linux executable mothur v.1.33.3 on Centos

I receive this message when I am the command line step ‘‘make’’ when trying to install it

mkdir mothur
cd mothur
unzip …/
make:*** No targets specified and no makefile found. Stop.

I do not know what to do; I installed it on my personnal pc and it worked fine at the make step…

If you type:


Do you get a bunch of files ending in *.cpp, *.hpp, etc? I suspect you’re in the wrong folder. You probably need to move up and over to where the contents of are being placed.


I am having a similar problem.
I downloaded the mothur version 1.35.1 and into a directory named ‘mothur-1351’.
I unzipped and typed ‘make’ but the error, “make: *** No targets specified and no makefile found. Stop.” resulted.
I cded into the source folder where a makefile is found and tried to run ‘make’ again. But it wouldn’t work. The resuting error is as follows:

gfortran -c -m64 *.f
g++ -O3 -DBIT_VERSION -DRELEASE_DATE="“3/31/2015"” -DVERSION="“1.35.1"” -DUSE_READLINE -I. -I calculators/ -I chimera/ -I classifier/ -I clearcut/ -I commands/ -I communitytype/ -I datastructures/ -I metastats/ -I randomforest/ -I read/ -I svm/ -arch x86_64 -c -o calculators/ace.o calculators/ace.cpp
g++: x86_64: No such file or directory
cc1plus: error: unrecognized command line option “-arch”
make: *** [calculators/ace.o] Error 1

I’d be glad if you can point me in the right direction as to how to get the software installed. My OS is CentOS 6.5.0.
I currently have mothur version 1.33.3 installed in the same folder and is conveniently called ‘mothur’, explaining why i’ve chosen to call this ‘mothur1351’. I don’t expect that that would affect anything, would it.

Thanks a lot.


Comment out line 29 from source/makefile

28 #if you are a mac user use the following line
29 TARGET_ARCH += -arch x86_64


Thanks a lot, Ian.
That was quite helpful.
‘make’ ran successfully. And Mothur-1.35.1 runs okay.
But if currently only runs from within the ‘source’ folder which for me is tucked many folders deep .
I’d love to be able to reach the file from anywhere else. Any advices??
I imagine I may need to edit my .bashrc file. Just not sure of the specific edits.
Thanks a lot

Just move mothur to whatever folder you want it to sit in, and then add a line similar to the following line in your .bashrc:

export PATH=/home/dwaite/mothur:$PATH

You’ll need to logout/login or restart your session before it takes effect though.


I have the same problem and i am not using mac, I am using opensuse v42.1 (leap)
any ideas?


Editing a .bashrc file in your home directory on linux should work just like it does on a Mac.