mothur

Make.contigs problem in mothur v.1.42.0 windows

#1

Hi,
I’m new to mothur and still learning my way through it.
I’m using mothur v.1.42.0 in Windows for MiSeq data.
When I ran make.contigs(file=stability.files, processors=8), I get an error message:

Processing file pair C:\mothur\ITS2\ALAMINOS-TG-2_1.FASTQ.GZ - C:\mothur\ITS2\ALAMINOS-TG-2_2.FASTQ.GZ (files 1 of 55) <<<<<
Making contigs…
[WARNING]: reading √Hÿ\ ∞]█Üú,│> expected a name with @ as a leading character, ignoring read.
[WARNING]: reading Bi^è┌QΦ expected a name with + as a leading character, ignoring.[WARNING]: names do not match. read √Hÿ\ ∞]█Üú,│> for fasta and Bi^è┌QΦ for quality, ignoring.[WARNING]: Lengths do not match for sequence √Hÿ\ ∞]█Üú,│>. Read 36 characters for fasta and 13 characters for quality scores, ignoring read.[ERROR]: finding negative quality scores, do you have the right format selected? http://en.wikipedia.org/wiki/FASTQ_format#Encoding
[WARNING]: reading √Hÿ\ ∞[╗ú¬▓}_┐Γ<èÆ─ expected a name with @ as a leading character, ignoring read.
[WARNING]: reading ╦⌐═L2o╬5╗{⌡Z{3╗#¿áâ┴¿óP expected a name with + as a leading character, ignoring.[WARNING]: names do not match. read √Hÿ\ ∞[╗ú¬▓}_┐Γ<èÆ─ for fasta and ╦⌐═L2o╬5╗{⌡Z{3╗#¿áâ┴¿óP for quality, ignoring.[WARNING]: Lengths do not match for sequence √Hÿ\ ∞[╗ú¬▓}_┐Γ<èÆ─. Read 9 characters for fasta and 13 characters for quality scores, ignoring read.[ERROR]: finding negative quality scores, do you have the right format selected? http://en.wikipedia.org/wiki/FASTQ_format#Encoding
[ERROR]: You have 1 sequences in your forward fastq file, but 0 sequences in your reverse fastq file. Please use the list.seqs and get.seqs commands to make the files match before proceeding.

How do I use the above command(s)? I keep getting this error:
[ERROR]: Invalid command.
Valid commands are: align.check, align.seqs, amova, anosim, bin.seqs, biom.info, chimera.bellerophon, chimera.ccode, chimera.check, chimera.perseus, chimera.pintail, chimera.slayer, chimera.uchime, chimera.vsearch, chop.seqs, classify.otu, classify.seqs, classify.svm, classify.tree, clearcut, cluster, cluster.classic, cluster.fit, cluster.fragments, cluster.split, collect.shared, collect.single, consensus.seqs, cooccurrence, corr.axes, count.groups, count.seqs, create.database, degap.seqs, deunique.seqs, deunique.tree, dist.seqs, dist.shared, fastq.info, filter.seqs, filter.shared, get.commandinfo, get.communitytype, get.coremicrobiome, get.current, get.dists, get.group, get.groups, get.label, get.lineage, get.mimarkspackage, get.otulabels, get.otulist, get.oturep, get.otus, get.rabund, get.relabund, get.sabund, get.seqs, get.sharedseqs, heatmap.bin, heatmap.sim, help, homova, indicator, kruskal.wallis, lefse, libshuff, list.otulabels, list.otus, list.seqs, make.biom, make.contigs, make.fastq, make.file, make.group, make.lefse, make.lookup, make.shared, make.sra, make.table, mantel, merge.count, merge.files, merge.groups, merge.otus, merge.sfffiles, merge.taxsummary, metastats, mgcluster, mimarks.attributes, nmds, normalize.shared, otu.association, otu.hierarchy, pairwise.seqs, parse.list, parsimony, pca, pcoa, pcr.seqs, phylo.diversity, phylotype, pre.cluster, primer.design, quit, rarefaction.shared, rarefaction.single, remove.dists, remove.groups, remove.lineage, remove.otulabels, remove.otus, remove.rare, remove.seqs, rename.file, rename.seqs, reverse.seqs, screen.seqs, sens.spec, seq.error, set.current, set.dir, set.logfile, set.seed, sff.multiple, sffinfo, shhh.flows, shhh.seqs, sort.seqs, sparcc, split.abund, split.groups, sub.sample, summary.qual, summary.seqs, summary.shared, summary.single, summary.tax, system, tree.shared, trim.flows, trim.seqs, unifrac.unweighted, unifrac.weighted, unique.seqs, venn.
[ERROR]: did not complete list.seq.

I read some threads in the forum but I keep getting more confused. Please help! Thank you very much.

#2

Hi there,

It looks like you are running mothur on a windows computer with files that are gzip compressed. Unfortunately, the windows version of mothur cannot decompress these files (the mac and linux versions can). If you are using windows, you’ll need to decompress those files and recreate your files file.

Pat

#3

Hi Pat,

Thank you so much for your response. I did decompress the files, and another error appeared:
[ERROR]: You have 133318 sequences in your forward fastq file, but 67365 sequences in your reverse fastq file. Please use the list.seqs and get.seqs commands to make the files match before proceeding.

I still do not get how list.seqs and get.seqs are used. Thanks so much for your help.

Best wishes,
kus

#4

Is it possible to get the raw data from your sequence provider? This error typically happens because the sequencing facility removes reads from one read but not the other.

Pat

#5

Hi Pat,

I’ve resolved the issues with list.seqs and get.seqs command, and was able to run make.contigs successfully. The pipeline I am following, proceeds to remove primers via cutadapt. I tried to install it but I was completely lost and wasn’t able to install it, until now. Is there any alternative you could suggest? Thank you so much!

#6

Sorry, we don’t use cutadapt. For cases where you need to remove barcodes and primers, we advise using the oligos option in make.contigs.

Pat

#7

I have used that option, worked fine. Thank you very much!