how to uninstall mothur 1.29.2 from ubuntu 12.04?


I’ve been running into trouble with the readline library when compiling MOTHUR 1.29.2 on Ubuntu 12.04. After facing problems when I first installed MOTHUR, I disabled readline for the time being and the installation worked fine.

Now, working with MOTHUR, I truely miss the functionality of readline so I went back to re-compile MOTHUR. This, however, does not work at all: On the terminal, I just see a list of all files in the directory but no compilation takes place. I thought that I therefore better remove MOTHUR and all her traces from my system before re-compiling it. I tried

sudo apt-get remove MOTHUR

(upper case, lower case) but this is obviously not the way to go as the terminal told me that “the package mothur is not installed so not removed”.

How do I remove MOTHUR from my system (so that I can start with a fresh version and hopefully get readline to work)?


Kim Milferstedt

The make clean command will remove all the object files so you can rebuild mothur from source.

imac:~ sarahswork$ cd desktop/mothur.source
imac:mothur.source sarahswork$ make clean
imac:mothur.source sarahswork$ make
gfortran -c -m64 *.f
g++ -O3 -DBIT_VERSION -DRELEASE_DATE="“4/01/2013"” -DVERSION="“1.30.0"” -DMOTHUR_FILES=""…/release"" -DUSE_READLINE -I. -arch x86_64 -c -o abstractdecisiontree.o abstractdecisiontree.cpp