Mothur Linux latest version

I am new in the forum, sorry if this is not the better place for the question… I had just downloaded the latest version for linux_64bit (without readline), however when I run it in the console it says that it is v.1.22.2 with last update in 2011. How could I get the 1.32.1? Thanks for your help.

Welcome to the mothur community! When I download the without readline version and run it I am seeing version 1.32.1. How did you start mothur? Could you have an older version of mothur on your machine that is in your path? Have you tried opening a terminal window, cding into the directory mothur is in and then starting mothur with ./mothur?

Thanks westcott for the fast replay. I had tried both linux executables (64_bit). When I unziped, mothur was installed directly, without “make”. When I saw that the version was not the last, I tried “make” but it did not work and I could not find the make-file neither. I cd into the mothur folder and I could run it, but the version is 1.22.1 from 2011. I am working in Ubuntu 12.04 with build-essential and readline libraries installed. It is the first time that I install mothur in linux. What might I be missing?