Installation problem in Ubuntu 9.10


I am having trouble installing mothur on Ubuntu 9.10. I downloaded the source code, unzipped the source code. However, whenever I use the make command I get the following error

make:*** No targtes specified and no makefile found. Stop.

Thank you very much for your help in resolving this.


Can you make sure that you have the readline library installed? You can install it by…

sudo apt-get install readline
apt-get install libreadline-dev

Alternatively, open the makefile and remove the lines that refer to the readline library and recompile.

Dr. Schloss

Thank you for the response. I entered the first command sudo apt-get install readline. The programs finishes reading package lists, building dependency tree, and reading state informaion. However, after this it says: E: Couldn’t find package readline.

I used the command: apt-get install libreadline-dev and this works fine.

After this I tried the make command, but get the same error ssying *** No targets specified and no makefile found.

I also tried deleting the following from the makefile

ifeq ($(strip $(USEREADLINE)),yes)

And I get the same error stating no targets or makefile found.

So, I changed directory futher to by saying cd Mothur.source and tried using the make command and get the following error
g++ -O3 sharedutilities.cpp -c -I. -o ./sharedutilities.o
make: g++: Command not found
make: *** [sharedutilities.o] Error 127

I am using Ubuntu 9.10 through Virtual Box. My host operating system is Windows 7.

I did not have issues installing mothur on my MacBook earlier and it runs fine there. I have shifted to a work computer which has better operating power, but is windows based.

I greatly appreciate your patience and help with this.
Ameet Pinto

edit CC = g++ in the makefile to point to gcc


Hi Robin,

I installed the g++ package using
sudo apt-get install build-essential

After this I ran make file (with readlines removed) inside the Mothur.source folder and mothur installed and is now running fine.

In summary:

  1. sudo apt-get install build-essential
  2. remove readline section from the beginning of the makefile
  3. cd mothur
  4. cd Mothur.source
  5. make

This seemed the resolve the problem. Thank you so much for your help.

Ameet Pinto